Custom Errors IIS 6

Topics: Administration, Troubleshooting
Apr 28, 2012 at 7:03 PM

Attempting to implement custom errors.

Orchard 1.4
IIS 6

When the URL has a dot in it, I get a custom error message I created outside Orchard.  Otherwise I get a custom error message inside orchard.

Here are sample URLs:

http://orchard.blockimaging.com/insideorchard
http://orchard.blockimaging.com/ouside.orchard

What do I have to do to make those both point to the error inside Orchard?

Apr 29, 2012 at 1:57 AM

So, for now, because I don't know any better, I've put an HTML redirect in the file that is not managed by Orchard.  The redirect goes to a bogus Orchard page that doesn't have a dot in it.  (For example: http://orchard.blockimaging.com/error)  So now the about two links look the same, except the second one shows a blank page for a brief moment before taking you the Orchard managed error.

Hopefully someone has a better solution.

Coordinator
Apr 29, 2012 at 3:46 AM

IIS6? Any possibility you could move to IIS7? IIS6 is almost ten years old, and IIS7 has been out for more than four years...

Apr 29, 2012 at 5:15 AM

That would be nice, but that decision is not under my control.

Coordinator
Apr 30, 2012 at 6:04 PM

I think this is an issue with the star mapping in IIS6, and I doubt there's much you can do about it beyond url rewrites.

Apr 30, 2012 at 7:13 PM

Okay. Thank you. Good to know. Fuel for and upgrade recommendation.

May 3, 2012 at 1:47 PM

I'm getting a similar error from my upgrade to 1.4

So if I go to a fake url

/thiswillbreak/

I'll get the NotFound.cshtml content, if I reload that page, IIS kicks in and returns the /404/ page

 

I "fixed" it to going back to normal 1.3 by adding existingResponse="Replace" I'm not sure if its right.

 

	<httpErrors errorMode="Custom" existingResponse="Replace">
			<clear />
			
			<remove statusCode="400" subStatusCode="-1" /> 
			<remove statusCode="404" subStatusCode="-1" /> 
			<remove statusCode="500" subStatusCode="-1" /> 
			

			
			<error statusCode="400" subStatusCode="-1" path="/400/" responseMode="ExecuteURL" />
			<error statusCode="404" subStatusCode="-1" path="/404/" responseMode="ExecuteURL" />
			<error statusCode="500" subStatusCode="-1" path="/500/" responseMode="ExecuteURL" />

		</httpErrors>  

Coordinator
May 3, 2012 at 4:45 PM

That's not the same problem at all. We used to have this bug but it was fixed a long time ago. Are you using the official 1.4 release?

Coordinator
May 3, 2012 at 5:00 PM

We have added a Passthrough setting in the web.config of 1.4. Maybe you missed this one when you migrated.