This project is read-only.

Writing modules for Orchard

Topics: Installing Orchard, Writing modules
Apr 18, 2012 at 9:42 PM

My team are developing a module to run in Azure, it works on Azure Emulator but we have problems to deploy in real Azure environment.

I have tried all that I found:

1. I downloaded the zip with Orchard 1.4 source code, it throw an exception when published to Azure from VS 2010:

"None of the constructors found with 'Public binding flags' on type 'Orchard.EnvironmentDefaultOrchardShell' can be invoked with the available services and..."

2. I download a pair of enlisted sources from but they don't have all the modules and ClickToBuildAzurePackage.cmd fail.

3. I download it's a Orchard packaged for Azure deployments, it works, but I can´t install any module, I install a module to package modules to Azure but the command "package module path" in the Orchard Shell doesn't work .

I don't know what more to try, I beg for help.

Apr 18, 2012 at 11:31 PM

Please follow the instructions from

If you download the source from CodePlex, you won't get the subrepositories. To get the whole thing, you need to clone it using TortoiseHg.

Apr 19, 2012 at 6:14 PM

Thanks very much for your help, it works now I can build, package Orchard and deploy it to Azure including my module and my theme.

Even more, the same project works too on Azure emulator, that's great!


Only one more cuestion for now: there is a way to continue my module development and packaging to Azure without compile hole Orchard?

Apr 19, 2012 at 6:36 PM

Unfortunately, at the moment, the Azure deployment model is still to deploy the whole package. So no.