Repository Issues

Topics: Administration, Installing Orchard, Troubleshooting
Apr 12, 2012 at 11:56 PM

Is anyone else having issues cloning the repository? I tried it a few times but it seems to abort every time.

% hg clone --verbose -- https://hg01.codeplex.com/orchard .
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 84826 bytes, expected 134291)

Apr 13, 2012 at 12:06 AM

Yep, see http://orchard.codeplex.com/discussions/351823.

Until then you can grab the subrepos yourself from: (I assume that's what you want to do right?)

src/Orchard.Web/Modules/Orchard.Forms = https://hg01.codeplex.com/orchardforms
src/Orchard.Web/Modules/Orchard.Rules = https://hg01.codeplex.com/orchardrules
src/Orchard.Web/Modules/Orchard.Tokens = https://hg01.codeplex.com/orchardtokens
src/Orchard.Web/Modules/Orchard.TaskLease = https://hg01.codeplex.com/orchardtasklease
src/orchard.web/modules/Orchard.Fields = https://hg01.codeplex.com/orchardfields
src/Orchard.Web/Modules/Orchard.Autoroute = https://hg01.codeplex.com/orchardautoroute
src/orchard.web/Modules/Orchard.Alias = https://hg01.codeplex.com/orchardalias
src/orchard.web/Modules/Orchard.Projections = https://hg01.codeplex.com/orchardprojections

Apr 13, 2012 at 12:24 AM

Okay. It just worked for me. It looks like its back up.

Coordinator
Apr 13, 2012 at 11:17 PM

We're getting moved to new servers. Hopefully we'll have much better performance after that.