Possible Hg repository corruption issue?

Topics: Troubleshooting
Apr 10, 2012 at 7:00 PM

Hi,

After attempting to get a local copy of the current repo using mercurial 2.1.1 and 2.1.2 Hg decides to stop cloning with the following messages:

requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 84826 bytes, expected 134291)

Since I heard sometimes the Hg repositories become corrupt due to issues on the server I am wondering if I have stumbled upon one of those issues (I get the same error at home and at the office)...

Any help would be appreciated, especially because I am trying to build a deployment package for an Orchard based demo running on Azure which needs to be up and running ASAP.

Apr 11, 2012 at 7:29 AM

Just figured out how to run Hg in debug mode and discovered it breaks here:

adding lib/yaml/YamlSerializer.dll revisions
files: 659/7274 chunks (9.06%)
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 84826 bytes, expected 134291)

Anyone else with the same problem or a possible fix?

Coordinator
Apr 11, 2012 at 7:49 PM

Please contact CodePlex support for any problem with their source control.

Coordinator
Apr 12, 2012 at 5:19 AM

I contacted the CodePlex folks about this.

Apr 12, 2012 at 8:58 PM
Edited Apr 12, 2012 at 9:13 PM

Hi Bertrand,

Sorry; was away for a while. Nice to see you already put things in progress :)

Hopefully they are able to fix this shortly, in the mean time I rolled out the default package available from the downloads page this afternoon so we at least have a small demo environment up and running

After they fixed it hopefully we are hopefully able to grab the source code so we will be able to drop a customized version on Azure...

Anyway, thanks for the help :)

Coordinator
Apr 14, 2012 at 12:17 AM

We're getting moved to new servers. Hopefully we'll have much better performance after that.

Mar 24, 2013 at 7:30 AM
Hi All,
I am trying to clone the source code since last two days. But I keep getting following error. Is this issue with Tortoise HG or with Orchard code. Iam quite lost. Can anyone help me how to fix this?


abort: stream ended unexpectedly (got 73950 bytes, expected 74950)
[command returned code 255 Sun Mar 24 11:54:08 2013]
Coordinator
Mar 25, 2013 at 1:30 AM
Please contact CodePlex support.
Apr 27, 2013 at 7:24 AM
All,
I also am having problems making a fresh clone. Tried several revisions and latest was this:
hg clone --rev 6678 https://hg.codeplex.com/orchard
abort: stream ended unexpectedly (got 458272 bytes, expected 2139088)
Is there something wrong I am doing? and is this usually a client or server issue?
TIA
Coordinator
Apr 27, 2013 at 9:43 PM
Please contact CodePlex support.
Apr 28, 2013 at 8:00 AM
Thanks Bertrand. I already did.
For what's it worth, I managed to get it to work from a different network (a little faster connection as I noticed it breaks at different locations).