This project is read-only.

Upgrading to v1.4

Topics: General
Apr 6, 2012 at 4:01 PM

So, I have code enlistment setup for a 1.3 site. I published the site and its working great. However, when I pull the latest for version 1.4 recompile, publish to a local folder, and then try to hit it using IIS locally with a local host, I get a 404. It's almost as if the routing is all messed up. I tried even setting the host header to be the full domain name and set it up to point to and still no dice.

Is there an issue with the routes in 1.4 compared to 1.3? What can I do to fix those routes to debug locally?

Apr 6, 2012 at 6:06 PM

Yes, routing of content items has completely changed in 1.4. See the "How to upgrade from a previous version" section in the release notes here: You should still be able to get into the dashboard at /admin. From there you can enabled the UpgradeTo14 module and use it to fix your routes.

Apr 6, 2012 at 7:53 PM

If I do that and update the routes using the module, won't I get hosed on the live site if they share the same SQL database?

Apr 6, 2012 at 7:59 PM

Well, if you're pointing a local 1.4 code instance at the same database as a live 1.3 instance, then yes. I would strongly recommend against doing that though, not just for the scenario of going from 1.3=>1.4, but just in general that sounds like a bad idea.

Can you just make a backup of the live database and restore it locally?

Apr 6, 2012 at 8:00 PM

Yes, I'm just being lazy as pulling the amount of data I need across the line isn't always fun. I'm sucking it up and doing that now though.

Apr 7, 2012 at 2:59 AM

So, I took the data, copied it locally, ran the 1.4 module, and am getting the following:

Value cannot be null.
Parameter name: source


An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentNullException: Value cannot be null.
Parameter name: source

Source Error:

Line 239:        void ActivateShell(ShellSettings settings) {
Line 240:            // look for the associated shell context
Line 241:            var shellContext = _shellContexts.FirstOrDefault(c => c.Settings.Name == settings.Name);
Line 242:
Line 243:            // is this is a new tenant ?
Apr 7, 2012 at 5:04 AM

Looks like one of your tenants has a bad settings.txt

Apr 9, 2012 at 3:10 PM

Just to bring everyone up to speed....

I've removed the defautl site from my App_Data folder. Hit the URL, copied my connection string and known properties over (kept same site name, table prefix, etc) and hit run. I can now enable the migrate14 module.

I migrated all of my items over with little issue. The only thing that didn't seem to migrate well were my blog posts. However, I wonder if that's because I'm using bertrandleroy's Vandelay.Industries module. I did get an exception on that so I'm going to see if upgrading that fixes this issue.

Finally, I had to rechoose the theme.

So, my only outstanding issue right now seems to be my blog posts. I'm working to resolve those issues though.

Apr 9, 2012 at 8:16 PM

Everything is working properly now. I just had to update the widgets.