deployed 1.4 site. Get error: 'The view 'ShapeResult/Display' or its master was not found'

Topics: Troubleshooting
Mar 8, 2012 at 4:40 AM

Hi there,

I have a site that I just updated to v1.4 and is now running fine on localhost.
I did not change anything besides updating Orchard to v1.4.

I then published my site to a local folder and ftp'd everything to the live server.

When I visit the live site I get the following error. I cannot access the dashboard either.
Any page I visit throws the same error.
Any idea what could be wrong?

Server Error in '/' Application.

The view 'ShapeResult/Display' or its master was not found or no view engine supports the searched locations. The following locations were searched:

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.InvalidOperationException: The view 'ShapeResult/Display' or its master was not found or no view engine supports the searched locations. The following locations were searched:

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

 

Mar 8, 2012 at 5:00 AM

Redployed with no changes and it works now. Strange...

Dec 5, 2012 at 7:32 PM

Is there a workaround for this? I have a local copy of an Orchard 1.4 site that i need to run long enough to export data from it. I am getting this message. What causes it and what is the workaround?

Coordinator
Dec 5, 2012 at 7:32 PM

Bad deployment most likely. I found WebDeploy to be a lot faster and less flaky than ftp.

Dec 5, 2012 at 7:47 PM

My Workaround: Download the .zip file of the right version of Orchard. Extract it over the local copy of the site (so that the corresponding files are overwritten). Site now runs. I never had any luck with WebDeploy  on my shared host.