Content Type does not create Item 1.4

Topics: General, Installing Orchard
Mar 7, 2012 at 6:03 AM

I'm trying (in 1.4) to create my first Conten Item from Content Type (Evenement); the same module runs in 1.3!.

I get the Admin form correctly;  which on saving should create a DB record. However, When hitting 'save'
I get a page saying:
...........
Evenement page created

Not Found
The page you are looking for does not exist
...............

And there is no page in 'Content Items'!
In 'Edit content type' I have parts: Common, Autoroute, Eve, Title (no fields).

The Site was created from scratch via WEB matrix!

what am I possibly missing!?
thanks for your time, ed

Driver:
//GET
    protected override DriverResult Editor(EvePart part, dynamic shapeHelper)
    {
      return ContentShape("Parts_Eve_Edit",
          () => shapeHelper.EditorTemplate(
              TemplateName: "Parts/Eve",
              Model: part,
              Prefix: Prefix));
    }

    //POST
    protected override DriverResult Editor(
        EvePart part, IUpdateModel updater, dynamic shapeHelper)
    {
      updater.TryUpdateModel(part, Prefix, null, null);
      return Editor(part, shapeHelper);
    }

Coordinator
Mar 8, 2012 at 1:03 AM

Do you see anything in app_data\logs? Did you try to attach a debugger?

Mar 9, 2012 at 6:29 AM

the logs showed that my module wanted to insert a record.

However, after some more tests I found:

when I do the data migration to 'Create' the record the 'migration.cs' looks exactly like in 1.3 !
But there is no record built when checking the Database !
the 'Orchard_Framework_DataMigrationRecord' shows 1 in the 'eve.Migrations'!

? Shouldn't the record be built (with nulls) after running 'codegen datamigration eve' ?

PS: no I have not yet attached a debugger? which one would you suggest?
thanks for your time and help, ed

when doing the updateFrom(1) ... the part and Content Type is built and looks like in 1.3
and in turn when trying to create a record I get original error!

public int UpdateFrom1() {
            ContentDefinitionManager.AlterPartDefinition("EvePart",
            builder => builder.Attachable());
        return 2;
        }
        public int UpdateFrom2() {
        ContentDefinitionManager.AlterTypeDefinition("Evenement", cfg => cfg
            .WithPart("TitlePart")           
            .WithPart("CommonPart")
            .WithPart("EvePart")
            .Creatable()
            .Indexed());
        return 3;
        }

Coordinator
Mar 9, 2012 at 6:46 AM

Debugger: Visual Studio.

Mar 18, 2012 at 8:16 PM

after alot of reading the Orchard doc and many trial and errors suddenly the record got created and all works now on 1.4 as it worked on 1.3.

However, I honestly cannot say why ... well I consider it closed
thanks to all, ed