This project is read-only.

Upgrading to 1.4 -> Directory Listing

Topics: Troubleshooting
Mar 6, 2012 at 1:19 AM

Hi there,

I decided to upgrade the simplest of my sites to v1.4.
I downloaded the App_Data and Media folders from my live siteand made symbolic directory links into a my source code enlistment (v1.2 - default branch).
I upgraded then.

When I launch my site the home page just shows a Directory Listing.
I was able to go into the dashboard and enable and run the Migrate to v1.4 module.

Still the same. Home page still shows the directory listing.

The log directory contains two empty files (0KB).

I have no clue how to proceed, what is wrong?



Mar 6, 2012 at 1:27 AM

It displays the directory listing when you go to /admin?

Mar 6, 2012 at 1:56 AM

Nope, admin works fine. It is the root page that shows the directory listing.

I just tried the same procedure and updated succefully from 1.2 to 1.3

I will try now to update from 1.3 to 1.4 and see if that makes a difference

Mar 6, 2012 at 2:04 AM

When you say you ran Migrate to 1.4, what exactly did you do and what results did you get (messages, etc.)? When you go to Contents, and edit the item that should be the home page, what do you see?

Mar 6, 2012 at 2:26 AM

I enabled the module and selected the 'Migrate to v1.4' from the left menu.

I selected all available types (Blog, Blog Post, List, Noticia, Page) and hit 'Migrate'
This is the output:
Blog was migrated successfully
BlogPost was migrated successfully
Some content items could not be imported. Please refer to the corresponding Report.
There are no content types with RoutePart

In this project I have no content types with custom fields.

When I go and list the content, all pages are listed as 'Page - page' the title does not display.
If I edit the page the title is blank.

I noticed that the title module was disabled when I did the migration to 1.4
Could this have anything to do with it?

Mar 6, 2012 at 2:41 AM

I got it to work.
During migration all content titles for Pages and Noticias (news) were lost.
The problem seems to be that no content was set as home page. After restoring the title and checking the 'Set as home page' on the appropiate content the directory listing was gone, and the correct content reappeared.

Before I even touch some of my more complex sites I would like to know why the Content titles were lost? Any ideas? 

Mar 6, 2012 at 8:27 AM

I also had the same kind of problem migrating an Orchard 1.3 instance to 1.4.

I had this kind of error in logs :

2012-03-01 14:58:53,798 [8] Orchard.Tasks.BackgroundService - Error while processing background taskNHibernate.QueryException: could not resolve property: TitlePartRecord of: Orchard.ContentManagement.Records.ContentItemVersionRecord   at NHibernate.Persister.Entity.AbstractPropertyMapping.ToType(String propertyName)   at NHibernate.Loader.Criteria.CriteriaQueryTranslator.GetPathInfo(String path)   at NHibernate.Loader.Criteria.CriteriaQueryTranslator.CreateCriteriaEntityNameMap()   at NHibernate.Loader.Criteria.CriteriaQueryTranslator..ctor(ISessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias)   at NHibernate.Loader.Criteria.CriteriaLoader..ctor(IOuterJoinLoadable persister, ISessionFactoryImplementor factory, CriteriaImpl rootCriteria, String rootEntityName, IDictionary`2 enabledFilters)   at NHibernate.Impl.SessionImpl.List(CriteriaImpl criteria, IList results)   at NHibernate.Impl.CriteriaImpl.List(IList results)   at NHibernate.Impl.CriteriaImpl.List[T]()   at Orchard.ContentManagement.DefaultContentQuery.ContentQuery`1.Orchard.ContentManagement.IContentQuery<T>.List() in c:\Users\sebros\My Projects\Orchard\src\Orchard\ContentManagement\DefaultContentQuery.cs:line 191   at Orchard.Blogs.Services.BlogService.Get(VersionOptions versionOptions)   at Orchard.Blogs.Routing.BlogPathConstraintUpdator.Refresh()   at Orchard.Tasks.BackgroundService.Sweep() in c:\Users\sebros\My Projects\Orchard\src\Orchard\Tasks\BackgroundService.cs:line 32

I suspect that the module Iroo.VersionManager can cause a conflict (I will try to retest with a restored backup)

or else the migration tried to affect the TitlePartRecord before it is associated as a part.


Mar 11, 2012 at 9:32 PM

I've got the same Problem as santiagoIT some ideas why all content pages with a route part are lost?


Mar 11, 2012 at 9:39 PM


I never figured out what the root problem was. The site I upgraded was pretty basic so I just went ahead and manually re-added the titles. Also some of the permalink's were lost in migration to v.1.4.
After having done that the site has been working just fine. After this experience however I have not dared yet upgrade any of the other bigger sites.


Mar 12, 2012 at 2:51 AM

This happens if you try to upgrade with the Migrate to 1.4 option before you enable the Title module. Make sure you enable Title at the same time as you enable UpgradeTo14 and then when you migrate you shouldn't have any problems.

I'm not sure if you can get the titles back after you've migrated, because the content type will no longer be available to migrate, so it would be a manual process at best. If you can go back to the older version first (I was able to) that would probably be better.