Updating to Orchard 1.4 with Lucene

Topics: General
Mar 1, 2012 at 7:11 PM

I may have found a problem with updating a site to Orchard 1.4 when using Lucene. I followed the instructions for migrating a site using the release version (NOT the source enlistment). The instructions indicate to move all the modules that you have installed on your existing site to the modules directory on the new 1.4 site. In my case, this included the Lucene module.

When attempting to navigate to the site, I took a big ole .NET error (forgot to screen print it). So I started peeling back the modules I had copied over and after deleting Lucene, the site was accessible. I simply went to Modules and installed the new version of Lucene and everything works fine.

So...if I'm correct and this is the case, you might want to add to the instructions NOT to copy over the Lucene module if it's being used on a current pre-1.4 site.

I'll test it out again when I try the migration again after Advanced Menu has been updated to work with 1.4