This project is read-only.

Missing CFS file for Search

Topics: Troubleshooting
Feb 29, 2012 at 2:48 PM

I'm having trouble with a sites search feature.  

Could not find file 'C:\webroot\websites\\www\App_Data\Sites\Default\Indexes\Search\_2j4.cfs'.

Any ideas how to get around this would be appreciated.  I've been banging my head for a bit and can't come up with a solution.

Feb 29, 2012 at 3:56 PM

Please delete the search folder and rebuild your index. What version of orchard are you using ?

Feb 29, 2012 at 5:49 PM

Ha, that worked... I tried deleting all the files in the folder before.

The site is using 1.3.0.

Removing the search 'folder' allowed me back into the Search Index view and it's now able to update the search index (just going to let the rock out for a bit until it's done).  

The Rebuild function is throwing an error right now: Lock obtain timed out: NativeFSLock@C:\webroot\websites\\www\App_Data\Sites\Default\Indexes\Search\write.lock

Is this caused from having the lock logging disabled?

Thanks for all your help!