This project is read-only.

Why are certain modules not being included in my build package?

Topics: Administration, Customizing Orchard, Installing Orchard, Troubleshooting, Writing modules
Feb 16, 2012 at 11:48 AM
Edited Feb 16, 2012 at 1:44 PM

Within my project I have the modules Orchard.Search and Orchard.Indexing. Locally working fine.

I run build "clean;compile;package" from the "Visual Studio 2010 x64 Cross Tools Command Prompt"

But the resulting .zip package included in ~/artifacts/MsDeploy/ does not include the modules Orchard.Search or Orchard.Indexing.

Now I was wondering if there was a configuration file or any such flag that has been unset for these modules for them not to be include in the build?

Many thanks,



Feb 16, 2012 at 6:09 PM

Good catch. Actually we do not embed those scripts directly in Orchard releases bu on the gallery instead. And you are using the same script to build your website which we might have recommended somewhere. So we definitely need another build script to get everything from your current enlistment.

Right now you can change the Orchard.proj file here:

      <MsDeploy-Exclude-Modules Include="
Remove any line for the module you want to embed. Or remove all lines.

Feb 16, 2012 at 6:10 PM

By the way, if you are using Visual Studio, you can use the MsDeploy Publish command on the solution, which will take everything also.

Feb 16, 2012 at 7:20 PM

Thanks for the reply, I will try this out tomorrow when I get into work!

Feb 17, 2012 at 9:38 AM

I have tried it out and it works fine.

I am just wondering why would these Modules would not be included on a build, is it purely to force the user to install these modules via the gallery?

Feb 17, 2012 at 6:02 PM

No, actually this build command is used to create the release package for Orchard, not for your websites. But on the other hand, we also tell people to use it ... so it's a problem. Can you file a bug for it ?