This project is read-only.

How to show the blog post body in the list

Topics: Troubleshooting
Jan 16, 2012 at 7:13 PM

I have installed Orchard Azure 1.3.10 on Azure and selected the Default recipe. I created a blog, essentially following the instructions here  The list of blog posts does not contain any of the body of the blog posts and I'm wondering what I'm doing wrong.  I've tried a couple themes and the behavior is the same.  Is this supposed to be working the the latest version?

Jan 16, 2012 at 7:18 PM

Have you "Published" your posts, and not just saved them ?

Jan 16, 2012 at 7:24 PM

Yes, the test posts have been published (via Publish Now button).  The posts show up on the blogs page with title, date, tags, number of comments, but no body.

Jan 16, 2012 at 7:26 PM

Have you changed the Flavor settings on the Blog Post ?

Jan 16, 2012 at 7:28 PM

Not knowingly.  How is that done?  Is that something I should have done but somehow missed in the documentation?

Jan 16, 2012 at 7:51 PM

Just to be clear: you are not seeing anything from the body; you are not seeing a summary of any kind? And you are using the out of the box configuration? Which recipe did you use at setup?

Jan 16, 2012 at 8:10 PM

I am seeing a summary, but no body.  I chose the Default recipe.

Let's say I have a blog post in Edit mode that looks like this:

Title: New Web Site
Body: We have a new home on the web. Blah Blah Blah... (several paragraphs of information in <p> tags)
Tags: Website
[x] Allow new comments
Owner: admin

publish it with [Publish Now] button, and here's what I see on the blog content page in the list:


New Web Site

Tags: Website

Jan 14 2012 7:17 PM

Jan 16, 2012 at 8:19 PM

And that's using the default theme? No change in

Jan 16, 2012 at 8:37 PM

Correct. I don't understand near well enough to venture into it at all yet.  I've tried several themes, all behave the same.  The default "Theme Machine" both classic and dark variations behave the same.  Super Classic as well.  It behaves the same both on Azure, and locally installed running under WebMatrix.

Jan 16, 2012 at 9:11 PM

What version are you using? Do you have any errors in app_data/logs?

Jan 17, 2012 at 1:06 AM

Version 1.3.10 Azure. Not exactly sure how to check the logs on Azure.  I wonder if it's just in the Azure package?

Jan 17, 2012 at 6:54 AM

No, they are in blob storage. You can use to look in there.

Jan 17, 2012 at 4:07 PM

I do not see any errors in the log files in app_data/logs. I wasn't able to figure out how to find App_Data\Logs directly on Azure, via the tool you mentioned, nor Azure Storage Explorer. However, since I am getting the exact same behavior on a local installation running under WebMatrix, I did see the logs there and they are empty.

Jan 17, 2012 at 7:55 PM

Can you install Designer Tools and activate the shape tracing feature? Then browse to your blog page and open the tool (see then open all the nodes you find under the content zone and copy the results here.

Jan 17, 2012 at 7:58 PM

I found the module that is causing the problem.  I retraced my steps and using the Web Platform Installer, I installed Orchard fresh, then I created the blog, and added a post, and lo and behold it worked.  Then added themes and modules gradually until it broke.  It turned out to be this module:

Forums- Version: 0.5.0
Introduces a forum module allowing users to create forums, threads and posts. Requires the Voting module to be installed.
Features: Forums
Author: Nicholas Mayne

I disabled the module and the blog started working.  Thanks for your help.  I'm guessing Nicholas Mayne should be told about this somehow.

Jan 17, 2012 at 8:02 PM

I'll send him e-mail. He's a friend :)

Jan 17, 2012 at 9:07 PM

Hey Chaps...

I think it maybe down to the generic style

 <Match DisplayType="Summary">
   <Place Parts_Common_Body_Summary="-"/>

I have raised an issue

Jan 17, 2012 at 9:30 PM

well yeah, you might want to restrict that match a little more...