404 page not found after publishing

Topics: General, Troubleshooting
Jan 14, 2012 at 7:39 PM

Hi Everyone,

 

I am new to orchard and just trying to publish my website for the first time. Site works great locally but when I publish to my hosting provider which is IIS 7 and ASp.NET 4.0  I just get a 404 error page not found.  I have tried on GoDaddy and another hosting provider dotnet-hosting.com.

Anything I might be missing? I havent done anything except use the default theme; was just curious to see if it would run outside of my local computer.

 

Any advice is appreciated. Seems like it should work right out of the box.

Thanks,

Flea

Coordinator
Jan 14, 2012 at 8:32 PM

How did you publish?

Jan 14, 2012 at 8:40 PM

I've tried using straight FTP with FileZilla and also tried just using the built in publishing with WebMatrix both FTP and WebDeploy.  The files look like they are all there but just receive 404.

Coordinator
Jan 14, 2012 at 8:48 PM

What directory did you deploy?

Jan 14, 2012 at 8:51 PM

I deployed to the wwwroot folder which my hosting provider has set.  To ensure it worked in general, I deployed a regular ASP.NET website I had and it rendered just fine, so this at least proved to me the folder was correct.  So I delete that standard website, redeployed orchard website and then just received a 404 page not found.

Coordinator
Jan 14, 2012 at 9:22 PM

Not my question, sorry. *From* what directory did you deploy? What directory did you copy there?

Jan 14, 2012 at 10:30 PM

I copied the following directories:

  • AppCode
  • Bin 
  • Config
  • core
  • media
  • modules
  • themes
  • global.asax
  • credits.txt
  • robots.txt
  • web.config
  • refresh.html
Coordinator
Jan 14, 2012 at 11:06 PM

Why do you have an appcode directory?

Jan 15, 2012 at 5:10 PM

My mistake; its a app_data;  not code.

Jan 15, 2012 at 8:12 PM

I can also deploy a basic MVC app out there and it works fine!

Jan 15, 2012 at 8:49 PM

FINALLY resolved the problem. On my hosting provider; I had to set my ASP.NET 4.0 to Integrated Pipeline.  By default it was just set on 4.0.

 

Once I set to 4.0 Integrated Pipeline the site worked perfectly.