Projector Widget

Topics: Troubleshooting
Jan 11, 2012 at 9:09 PM

I am using changset '6059f573ee03' and I am having the following problem. 

Trying to add a Projector Widget and the Query Display dropdown always defaulting to first item in the dropdown after saving. Please advise.

Jan 11, 2012 at 10:56 PM

Please file a bug with repro steps.

Jan 17, 2012 at 6:16 PM

It seems like it is breaking in newer version since I have used version (Changeset '6059f573ee03') to create projector queries. If you upgrade Orchard with latest version (1.x branch). I am getting behavior described above. My question is Can I do that theyway I am upgrading or I have to use the latest version of Orchard and re create the projector queries again ?


Jan 17, 2012 at 6:19 PM

Have you read the discussion in the Announcements section about recent changes on Projector ?

Jan 17, 2012 at 8:25 PM


Thanks for letting me know. I followed the instruction to re create queries. But when I tried to enable Projector, it gives me a message 'Some features need to be upgraded: Orchard.Projections' . When I tried to upgrade it error out. Is this normal ?

Jan 17, 2012 at 9:17 PM

It should not display the message if the message was already installed. Because the migration number didn't change at all.

Jan 17, 2012 at 9:36 PM

One more thing I am running into. Simple query like 'Give me all product where type(Text field) is equal to [anything ] does not work. I guess I am screwed :)

The query that is working if I use Content Type for e.g Product is working. I am confused

Jan 17, 2012 at 9:52 PM

If projector can do it, so can you.