How to override or suppress default Orchard jquery version?

Topics: Customizing Orchard, General, Troubleshooting, Writing modules
Dec 27, 2011 at 9:57 PM

Some of my pages are using jquery 1.7.1, but the Orchard jquery module uses 1.6.4 (included at the bottom of the page's HTML). To get my pages working I had to do the code below to ensure that the browser loads 1.6.4 first, and then 1.7.1:


I'd rather just not include 1.6.4 at all on these pages. Is there a way to prevent Orcard from rendering the jquery include? 

Dec 27, 2011 at 10:21 PM
Edited Dec 27, 2011 at 10:21 PM

Update the jQuery module, submit a patch.

Dec 28, 2011 at 3:35 AM

ah, I wasn't sure if there was a reason that Orchard was still on 1.6.4. I'll try to patch it to 1.7.1 then.

Dec 28, 2011 at 1:25 PM

Better take a look at the source first, I can recall I've seen Sebastien updated jQuery recently.

Dec 28, 2011 at 6:42 PM

@Piedone: I got the latest source from Dec 19th I believe, and it's still using 1.6.4. Did you see that check-in in one of the branches?