404 Error After Install

Topics: Installing Orchard
Dec 26, 2011 at 9:08 PM

I have installed to my host (Arvixe.com) by simply copying the contents of the Orchard folder as detailed in the installation instructions.

The installation does not seem to have worked. I have not been able to configure the site, I am getting a 404 error for the default page and even static pages that I upload manually. 

Has anyone seen this before? 

Coordinator
Dec 27, 2011 at 6:46 AM

Not sure what instructions you followed. What's in the folder?

Dec 27, 2011 at 8:47 AM
Edited Dec 30, 2011 at 10:54 AM

I followed the instructions for installing using the zip file. The contents of my wwwroot directory on the host machine is:

  • App_Data
  • bin
  • Config
  • Core
  • Media
  • Modules
  • Themes
  • CREDITS.txt
  • Global.asax
  • LICENSE.txt
  • Refresh.html
  • Web.config

 

 



Coordinator
Dec 27, 2011 at 8:54 AM

Then your host is not properly configured. Is the app pool where the app is configured for ASP.net 4?

Dec 27, 2011 at 9:06 AM

The app pool is set as '4.0 (Integrated)'

I think something must be at least partially working. When the orchard app files are uploaded the static pages I upload dont get served. I tried deleting the orchard files. Without the orchard files the static pages get served as expected.

Coordinator
Dec 27, 2011 at 8:51 PM

Then it may be an incomplete upload.

Dec 30, 2011 at 10:54 AM

I have tried a number of times now with different versions of the downloaded files - all with the same results, so I dont think its an incomplete upload.

I notice that it uses log4net. Does anyone have a sample configuration that I could use in order to get some debug information to help me diagnose this?

 

Coordinator
Dec 30, 2011 at 8:04 PM

You could take a look at app_data\logs, yes.

Jan 3, 2012 at 8:17 AM

I have this fixed now. The 404 error was due to some kind of error on my host - the control panel was reporting  '4.0 (Integrated)', but in fact it was using  '4.0 (Classic)' - something had got confused when my host moved a static ip address from one of my domains to another.

After that was fixed I got a 500 error. This has been resolved also - the app did not have write permissions to the App_Data directory.

All working now.

Thanks bertrandleroy, your comments were right on the mark.