Desperately trying to run Orchard on production Server

Topics: Installing Orchard, Troubleshooting
Dec 22, 2011 at 7:35 PM

I uploaded my Orchard site to a production server and I received this message when I hit the domain:

 

None of the constructors found with policy 'Orchard.Environment.AutofacUtil.DynamicProxy2.ConstructorFinderWrapper' on type 'Contrib.ImageField.Drivers.ImageFieldDriver' can be invoked with the available services and parameters:
Constructor 'Void .ctor(Orchard.IOrchardServices, Orchard.Media.Services.IMediaService)' parameter resolution failed at parameter 'Orchard.Media.Services.IMediaService mediaService'.
Constructor 'Void .ctor(Orchard.Media.Services.IMediaService)' parameter resolution failed at parameter 'Orchard.Media.Services.IMediaService mediaService'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: Autofac.Core.DependencyResolutionException: None of the constructors found with policy 'Orchard.Environment.AutofacUtil.DynamicProxy2.ConstructorFinderWrapper' on type 'Contrib.ImageField.Drivers.ImageFieldDriver' can be invoked with the available services and parameters:
Constructor 'Void .ctor(Orchard.IOrchardServices, Orchard.Media.Services.IMediaService)' parameter resolution failed at parameter 'Orchard.Media.Services.IMediaService mediaService'.
Constructor 'Void .ctor(Orchard.Media.Services.IMediaService)' parameter resolution failed at parameter 'Orchard.Media.Services.IMediaService mediaService'.

Source Error: 

Line 24:                              && filterContext.ActionDescriptor.ControllerDescriptor.ControllerName == "Account";
Line 25: 
Line 26:             if (!AdminFilter.IsApplied(filterContext.RequestContext) && !isAuthPage && !_authorizer.Authorize(StandardPermissions.AccessFrontEnd, T("Can't access this website"))) {
Line 27:                 filterContext.Result = new HttpUnauthorizedResult();
Line 28:             }


Source File: c:\Websites\pryor.com\training\Modules\Orchard.Users\Security\AccessFrontEndFilter.cs    Line: 26 

 

I have been unable to Deploy Orchard from the enlistment using Visual Studio, so I just took Orchard.Web and Uploaded the source code. That is just some background information.

Has anyone seen this error? Is it related to some security setting in a config file somewhere?

 

Please advise.

 

Thanks

Oceantrain

Coordinator
Dec 23, 2011 at 12:39 AM

Looks like an incomplete upload.