Cannot install Lucene

Topics: Customizing Orchard
Dec 16, 2011 at 6:48 AM

Hi,

 

I have installed Searching and indexing modules and enable those, When i try to install Lucene module following error raise,

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Coordinator
Dec 16, 2011 at 7:11 AM

Do what it says, so you can have a proper error message, or look in app_data\logs.

Dec 16, 2011 at 7:22 AM

here is error message have u idea abt this error

2011-12-16 08:24:44,875 [24] Orchard.Environment.Extensions.ExtensionManager - Error loading extension 'Lucene'System.Web.HttpCompileException (0x80004005): c:\HostingSpaces\eProp\eprop.co.za\wwwroot\Modules\Lucene\Services\LuceneSearchBuilder.cs(14): error CS0535: 'Lucene.Services.LuceneSearchBuilder' does not implement interface member 'Orchard.Indexing.ISearchBuilder.WithField(string, float)'   at System.Web.Compilation.AssemblyBuilder.Compile()

Coordinator
Dec 16, 2011 at 8:48 AM

Most probably, there is a mismatch between the version numbers of Orchard and the module.

Dec 16, 2011 at 9:05 AM

can u updgrade orchard or do i want install newly?

Coordinator
Dec 16, 2011 at 7:24 PM

Read this: http://docs.orchardproject.net/Documentation/Upgrading-a-site-to-a-new-version-of-Orchard