Empty Widgets list (no Zones)

Topics: Installing Orchard, Troubleshooting
Dec 6, 2011 at 3:32 PM

Oops - I no longer have any zones available to select and thus cannot add widgets. I am using the default theme (The Theme Machine).

Any ideas what could be wrong?



Dec 6, 2011 at 5:05 PM

Have you changed anything in the Theme, or added a Child Theme by chance ?
If so, please open the Theme.txt manifest, and add the Zones again, save, enjoy (theory only here)

Dec 6, 2011 at 5:12 PM

AFAIK, I did not change the theme.
BTW: I am using the hosted trial service... 

Dec 6, 2011 at 5:18 PM

This list of zone is a direct clone of the Zones lines in the manifest which is provided with a theme, here:

Zones: Header, Navigation, Featured, BeforeMain, AsideFirst, Messages, BeforeContent, Content, AfterContent, AsideSecond, AfterMain, TripelFirst, TripelSecond, TripelThird, FooterQuadFirst, FooterQuadSecond, FooterQuadThird, FooterQuadFourth, Footer 

If you never changed it, there might be an issue with the hosting, or the cache maybe. What trial are you using ? Can I access the account ? Can you do an "iisreset" by any mean, maybe altering the web.config ?

We have never seen this behavior, even on the cheapest hosters. 

Dec 6, 2011 at 5:48 PM

It is this one: http://tvmschwimmen.sandbox.sitefinity.com/

Dec 6, 2011 at 5:53 PM

Is there a bug typo in the link, or are you on the wrong forum ...
You gave me a Sitefinity website, you are on Orchard forums ;)

Dec 6, 2011 at 5:56 PM

Hahahaha :) copy & paste error ;)

Lemme check what you said above (note to self: do not work when being sick...)

Dec 6, 2011 at 5:58 PM

I am running it locally, actually. In IIS Exopress.

iisreset did not help.

Dec 6, 2011 at 6:02 PM

Definitely should work if local. If you want to d o a shared session to nail it, ping me using the contact page.