Breakthrough By Learning (1) OrchardDesignerModule & (2) Orchard Code Generation Module

Topics: Customizing Orchard
Dec 5, 2011 at 7:38 AM
Edited Dec 28, 2011 at 4:55 PM

Best wishes for ALL The Orchard Community!

I need your  help as described below:

Having learnt the importance of  (1)  OrchardDesignerModule & (2) Orchard Code Generation Module, I tried to initialize both but so far I have not succeeded. BOTH ARE INSTALLED BUT NOT ACTIVATED:

(1)   OrchardDesignerModule: I explored two docs and acted accordinlgy and got the designed tool installed that can split into three features: Shape Tracing, URL Alternates & Widget  Alternates. " The Designer will be shown in the Dashboard. You can activate the feature by going under the configuration and  then to manage features and that  the indicator (a small black dot) will be on the right side of your browser page." I read all this in at least two docs. I tried much. The problm is Features are Installed but not activated EVEN AFTER GREAT EFFORT.

(2)   Orchard Code Generation Module: I read in three docs :"Thre is Orchard.exe, there is orchard.web. Open the Command Line not in the Orchard.exe but in the Orchard.web."  I tried the both and much more. VS gets launched but not the Command Line.

Kindly guide me to some more detailed and comprehensive docs.

Before this Mr.Bertrandleroy has ansered my two questions of elementary nature. I am very much thankful to him for the help.

 

 

Dec 5, 2011 at 4:45 PM

1) Is the feature enabled? Did you get any errors?

2) Have you double-clicked on Orchard.exe?

See:

http://docs.orchardproject.net/Documentation/Installing-modules-and-themes-from-the-gallery

http://docs.orchardproject.net/Documentation/Using-the-command-line-interface

Dec 11, 2011 at 8:24 AM

Hi Randompete!

Sorry for late replying.

1. Yes feature is enabled and I did not get any error.

2. Yes I have double clicked but in vain.

Kindly  suggest some further hints.

Thank you in anticipation.

 

 

Dec 11, 2011 at 9:13 PM

Well, what happened when you double-clicked?

Is there anything recent in your error/debug logs (App_Data/Logs)?

Actually if you've enabled the features they are probably working. If you go to a site page, you should see a new thin blue bar at the bottom of the screen which pops up to show you the shape tracing console. Do you see that?

Dec 28, 2011 at 1:56 PM

Hi Randompete thank very much for replying my trivial questons.

 

For seeing "a new thin blue bar" and in some other documnet "a small tool bar at the bottom of your browser window" and in some third documnet with a slightly altered versions of it, I left no stone unterned but in vain.

I think the limitation on my side may be some deep-rooted one. Following error is shown when when I  tried  to install a theme through Orchard Gallery. It may serve an indicator to the real problem.

 

"There was an error installing the requested package. This can happen if the server does not have write access to the '~/Modules' or '~/Themes' folder of the web site. If the site is running in shared hosted environement, adding write access to these folders sometimes needs to be done manually through the Hoster control panel. Once Themes and Modules have been installed, it is recommended to remove write access to these folders."

 

Thanking in anticipation.

Coordinator
Dec 28, 2011 at 9:59 PM

It means that the account used by the web server (usually something like IIS APPPOOL\ASP.NET v4.0) needs write access to the Themes and Modules folders in order to be able to install new themes and modules.

Jan 1, 2012 at 6:52 AM

Best wishes for ALL The Orchard Community!

Hi Bertrandleroy!

Thank very much for giving a solid/concrete hint for solving the problem. I googled "IIS APPPOOL\ASP.NET v4.0)" and also opened the Control Panel "User Accounts" and went upto " Change User Accounts Control Settings" BUT could not find something like IIS APPPOOL\ASP.NET v4.0 to allow  write access to the '~/Modules' or '~/Themes' folder of the web site. Kindly  guide me towards the LOCATION OF THE REQUIREED IIS FOLDER FOR DOING THE NEEDFUL.

Thanking in anticipation!

Coordinator
Jan 1, 2012 at 7:19 AM

http://learn.iis.net/page.aspx/624/application-pool-identities/

Jan 4, 2012 at 5:03 AM

Thank you very much for continued help! I have started exploring and reading the site referred by you.BUT INITIALLY QUESTION UNDER THIS SUBJECT WAS:

1. "The Designer Module has been downloaded and also all the three features enabled, BUT "small blue bar" is nowhere visible EVEN after minute scrutiny.

2. "The Developer Module is also when downloaded and its two features enabled, For open Command-Line is not opened EVEN after trying many ways e.g. through Orchard.exe,Orchard.web etc.

3."THIRD INDICATION: When I  put text  (30 pages) in Orchard Page, and tags added, The tags were visible at the top. BUT text could never be pulled up when clicking the tags.

Thanking in anticipation.

Coordinator
Jan 6, 2012 at 7:59 AM

I have no idea what you're doing wrong. This is all pretty straightforward.