Problems enabling Intellitrace in Azure

Topics: Troubleshooting
Dec 2, 2011 at 6:00 PM

I'm trying to deploy to Azure with Intellitrace turned on.

I've attempted 2 different methods and both have failed.

Method 1: Attempting to modify the build script and adding parameters /p:EnableIntelliTrace=true; IntelliTraceConnectionString="BaseEndpoint=core.windows.net; Protocol=https;AccountName=storageaccountname;AccountKey=storagekey" as outlined in Grant Holiday's post (http://blogs.msdn.com/b/granth/archive/2011/02/20/intellitrace-for-azure-without-visual-studio.aspx)

Method 2: Publishing from inside VS. The problem here is that the themes, modules, and core are not deployed and the site does not function.

What is the proposed method of publishing to Azure with Intellitrace enabled?

Thanks,
Bill

Coordinator
Dec 2, 2011 at 6:12 PM

There is no proposed method. You are probably the first person to attempt it.

Dec 2, 2011 at 6:28 PM

We're currently having a performance issue (only in Azure). Are there any other tools available to us that could help us track down the problem?

Coordinator
Dec 2, 2011 at 7:20 PM

I'm not sure, but a first thing to check is that the database, the hosted service and the blog are in the same datacenter.

Dec 2, 2011 at 7:23 PM

The current hack that I used to allow me to Intellitrace was to deploy Orchard via VS.

After that was complete I jumped on the box and copied over the Core / Modules / Themes folders and the site was able to run and provide us with the data we needed.

Bill