Cant install packages

Topics: General, Troubleshooting
Nov 24, 2011 at 12:37 AM


All of this was done on my local machine.

I installed Orchard from within WebMatrix a few days ago

I installed the Contoso Theme

I followed the instructions for the HelloWorld module and the Simple Commerce Module , and they work fine: this entailed adding modules from the gallery from within the dashboard: like the Code Generation Module

Today, if I try to install any modules from the gallery from within the dashboard, I get the following message with a red background:

Package installation failed.

There was an error installing the requested package. This can happen if the server does not have write access to the '~/Modules' or '~/Themes' folder of the web site. If the site is running in shared hosted environement, adding write access to these folders sometimes needs to be done manually through the Hoster control panel. Once Themes and Modules have been installed, it is recommended to remove write access to these folders.
The remote server returned an error: (404) Not Found.
I go into the Requests section of Web Matrix, and it shows the request to grab the Messaging module:
it says
302.0 Object Moved
Path C:/Users/Rick/Documents/My Web Sites/RickHodder/Packaging/PackagingServices/InstallGallery
Did the orchard project change the place where the gallery pulls from?
I didnt make any changes to the machine, and I looked in the windows update log, and see nothing that might have change rights.
Any ideas?
Nov 24, 2011 at 1:01 AM

We did change the place, but put the required permanent redirects from the old addresses so your instance should follow them. So yes, it's a 302 but that should be automatically followed.

Nov 24, 2011 at 1:09 AM

Thanks Bertrand,

I'll try again tomorrow - maybe my ISP's servers havent gotten the news yet.


Nov 24, 2011 at 1:19 AM

I don't think your ISP has anything to do with it. The redirect should be followed. I don't understand why it isn't. Workaround is to download manually from the gallery and install locally.

Nov 24, 2011 at 1:02 PM
Edited Nov 24, 2011 at 1:03 PM

See my thread( )

It tries to connect to "" which is 404.

Nov 25, 2011 at 1:05 AM

lol - just responded to that thread before I checked this one. Hope it helps you

Nov 26, 2011 at 1:31 AM

I was searching around on the net, and I noticed the following address that looks close, and gives back a list of packages:

I'm not at a place that I can test this: I will test this when I get home and see if this solves the problem.



Nov 26, 2011 at 11:02 AM

I have the same problem suddenly. Guess this has to do with the Gallery relocation.

Nov 26, 2011 at 5:23 PM

The address I just mention is wrong: it looks like the feed service has two items in it: packages and screenshots, then it calls the Packages and Screenshots children.

So no luck there.

Bertrand, do you have any ideas?

I cannot even get to the gallery now, so I cant even download modules

Nov 26, 2011 at 5:53 PM

I "fixed" it but have no idea how - I created a new Orchard site from webmatrix, ran the site, then opened the first site in web matrix and ran the site, and I was able to see the gallery, and even able to install a module.


Nov 26, 2011 at 9:28 PM
Edited Nov 26, 2011 at 9:42 PM

I wasn't working just moments ago.  I tried to edit the setting in Settings/Gallery and it wouldn't accept the values until I put in "".  Then I went back to the Modules/Gallery and successfully installed a package. 

Nov 27, 2011 at 12:29 AM

I think Bertrand might have fixed it somehow - he's good that way ;-)

Nov 28, 2011 at 10:33 PM

No, Sébastien did.

Nov 28, 2011 at 10:56 PM

Oh, cool! Thanks Sebastien!

Nov 30, 2011 at 3:58 PM
Edited Dec 6, 2011 at 2:09 PM

The Package Updates doesn't seem to work with the latest update module :

On Monday, I installed manually (uploading from my computer) the Module Combinator 0.8.1.

In Orchard, In a site in which I changed the url of the gallery Feed by, there are no Updates available while version 0.8.2 is in the packages Feed.

I re-changed the Url of the gallery Feed Setting with but it doesn't change, still no updates.

Does anyone have this problem?

Dec 6, 2011 at 3:51 PM

Did anyone have managed to retrieve some 'Package Updates' since the gallery has moved?

Dec 6, 2011 at 6:13 PM

I tried the module mid-November, I don't know before of after the Gallery relocation, but it hasn't worked. Last time I checked was definitely after the relocation and it wasn't working either.