Orchard Multitenancy

Topics: Troubleshooting, Writing modules
Nov 18, 2011 at 7:01 AM

Hello,

I have started working with Orchard and I want to set Multi-tenant website.

Could anyone help me how to proceed with the multi-tenancy module?

 

Coordinator
Nov 18, 2011 at 7:02 AM

http://orchardproject.net/docs/Setting%20Up%20a%20Multi-Tenant%20Orchard%20Site.ashx

Nov 18, 2011 at 8:57 AM

I have try it but it did not work?

Could you guide me what step I should do?

Does Multitenancy real increase the performance of the website and reduces the memory usage?

Actually my website with a single page is using around 400MB of memory

Nov 18, 2011 at 9:39 AM

In what way didn't it work? Did you get an error?

Multitenancy doesn't increase performance. It just means that an additional website doesn't add much performance cost - it will add a small amount to your memory usage, as opposed to creating a whole new instance which would use a whole extra 400mb.

Nov 18, 2011 at 10:31 AM

I am using an external database and the table of the tenant is not showing in the database and i think am not able to set up the tenant properly.

When i click on setup, it goes to the website set without seeing any change concerning the tenant..i can't find the suspend link as well.

Do i have to do some dns settings?

Nov 18, 2011 at 10:34 AM

- Did you specify a table prefix for the tenant, or are you using a different connection string to your base instance?

- Is this on localhost or your production server? You need to access the tenant through a different domain for it to work.

Nov 18, 2011 at 10:41 AM

Ya, i have specified the table prefix (tbl). I am using a connection string connect on to sql server. It's on my production server and i have used a different domain

Nov 18, 2011 at 10:46 AM

The table prefix should be unique to the tenant, rather than "tbl" I would use something more descriptive of the tenant.

You need to check you are accessing the server through the tenant's domain, not your default domain.

Maybe there was an error with the connection string or SQL permissions; check your error logs (App_Data/Logs) to see if anything is being thrown.

Coordinator
Nov 18, 2011 at 7:32 PM

Do you mean the tables for the tenant or the table of tenants? (because there is no table of tenants).

Nov 22, 2011 at 10:42 AM

Hi,

I have been able to make the multi tenancy work on localhost, i have try to publish the website. Now i have transfer the published version to the server and its not working. Any help, how to make it work with the published version?

Nov 23, 2011 at 10:06 AM

Hi,

I have two orchard website where each of them has custom theme, Is it possible to make one tenant to other?

Nov 23, 2011 at 3:30 PM

Yes, each tenant has its own admin area where you can have a completely different list of enabled module/themes.

Nov 29, 2011 at 11:11 AM

Hi,

I having some problem, i am able to post some blog by live writer in a tenant website? Can anyone help?

Nov 29, 2011 at 1:12 PM

Have you enabled the Remote Publishing module in that tenant's admin?