Maintenance operations this week on Gallery

Topics: Announcements, General
Coordinator
Nov 15, 2011 at 4:41 PM

I'm going to move the gallery to a new server this week, which will have some temporary repercussions, such as:

  • inability to submit new modules and themes
  • inability to create new accounts
  • suspension of download stats, uncounted hits and downloads
  • inability to edit existing packages
  • plain unavailability

I'm going to try to keep the last one to a minimum. Thanks for your patience.

Bertrand

Nov 18, 2011 at 2:34 AM

Will you let us know when things are running smoothly again? I have a new module to release :)

Coordinator
Nov 18, 2011 at 2:42 AM
Of course.

Sent from my TI-99/4A

From: randompete
Sent: 11/17/2011 7:34 PM
To: Bertrand Le Roy
Subject: Re: Maintenance operations this week on Gallery [orchard:279538]

From: randompete

Will you let us know when things are running smoothly again? I have a new module to release :)

Coordinator
Nov 19, 2011 at 5:50 AM

Apologies to all module and theme authors who tried to submit their creations these last few days. We've had a few unexpected hiccups but you should be good to go now.

Many many thanks as usual to Sébastien who spent countless hours debugging this thing.

Nov 19, 2011 at 1:19 PM

I submitted a new package called "Audit" but it hasn't appeared yet. I got the usual "it will take a minute to appear" message but it's been over half an hour I think. Is there still a problem?

Coordinator
Nov 19, 2011 at 10:09 PM

Apparently, yes. It is available from the gallery tab in Orchard. It's just the front-end that is not showing it.

Developer
Nov 23, 2011 at 10:55 AM

It seems that logging in by user name is gone (always returns false) and it's only possible to log in with the e-mail address.

Coordinator
Nov 23, 2011 at 3:58 PM

I can log by username... What's yours ?

Developer
Nov 23, 2011 at 4:03 PM

Hmm, now it works (it's "Piedone" BTW). I'm pretty sure I've used the right password (the several times I tried), so it's strange. Looks like a false alarm, then.

Nov 25, 2011 at 6:40 PM

I'm not sure if the gallery is still having problems, but I wanted to let you know that I'm having issues executing a recipe with a module directive in there.  In my recipe, I have the following line:

  <Module packageId="Orchard.Module.Contrib.ImageField" version="1.1.2" />

I even tried it with the newer version (1.1.3).  I get the following error when it tries to run:

Error executing command "setup"

--------------------------------------------------------------------------------
Recipe execution with id 47ed3c728f524e098c70a9e4d57c8bcb was cancelled because the "Module" step failed to execute. The following exception was thrown: There was an error installing the requested package. This can happen if the server does not have write access to the &#39;~/Modules&#39; or &#39;~/Themes&#39; folder of the web site. If the site is running in shared hosted environement, adding write access to these folders sometimes needs to be done manually through the Hoster control panel. Once Themes and Modules have been installed, it is recommended to remove write access to these folders.. Refer to the recipe journal for more information.
--------------------------------------------------------------------------------

I'm fairly sure this isn't a permissions issue, as I've never had problems with this before.  

Nov 25, 2011 at 8:31 PM

yesterday  i also have the same issue:

not just <Module packageId="Orchard.Module.Contrib.ImageField" version="1.1.2" />

any <Module packageId="any new model"  />

Developer
Nov 27, 2011 at 3:39 PM

I can't update my Combinator module. I've uploaded a new version yesterday. Although everything seemed to work and I got to the "Your module will appear...." message, there is no trace of it. The updated version doesn't appear anywhere.

When I try to edit the module page to re-upload, there is a message "This is not the recommended version. The current recommended version is 0.8." I've uploaded version 0.8.1, but this version appears nowhere, even on the edit page it says 0.8. When I click "Make recommended", nothing really happens. I can't re-upload the package as it says such a package is already there. I got checkmated.

Developer
Nov 28, 2011 at 5:52 PM

Also, now the Update feature seems not to work: "Package retrieve error: The remote name could not be resolved: 'orchardgalleryproxy.cloudapp.net'". This is with the new gallery service url.

Coordinator
Nov 28, 2011 at 6:13 PM

Hi guys,

Just to let you know I am working on all those issues ... and I am as sad as you if not more :/

I'll keep you posted.

Coordinator
Nov 28, 2011 at 6:37 PM

@Luke, there is a workaround for your issue. Uee this attribute in the <Module /> tag:

repository="http://packages.orchardproject.net/FeedService.svc"

It will force the location of the packages feed

 

<Module packageId="Orchard.Module.Contrib.ImageField" version="1.1.2" repository="http://packages.orchardproject.net/FeedService.svc"/>

Coordinator
Nov 28, 2011 at 7:32 PM

@Piedone

Your issue should be fixed too
And by the way @Luke, you should not need to specify the service url anymore. 

Developer
Nov 28, 2011 at 7:39 PM

Great, both of my problems are gone! Thanks!

Developer
Dec 18, 2011 at 7:09 PM
Edited Dec 18, 2011 at 7:15 PM

I noticed this earlier (I think that was even before the migration), but the problem persists: apparently I can't upload a screenshot for my theme. It looks like it's uploaded, I finish the wizard but the screenshot is not shown.

BTW I recently noticed a disturbing phenomena that could be a result of distributed caching or something similar: sometimes subsequent pageviews of the gallery show versions of the site at multiple times (e.g. download counters vary or on one page view the latest modules list is up-to-date, on another not). Also it matters if I'm logged in or not (e.g. after the - of course logged in - upload of a new module I can see it in the latest modules list, but as an anonymous user not). Sometimes it also happens that although previously I logged in, I see a page as an anonymous user (there is the Sign In link, etc.), however really I'm still logged in (and in the next page view the site also correctly shows this)...

Coordinator
Dec 19, 2011 at 11:08 PM

Caching is only active on anonymous users, and different servers may answer to your requests, with different cache versions.

Are screenshots not shown even when you are authenticated?

Developer
Dec 20, 2011 at 9:52 AM

No, they're not.

Developer
Dec 22, 2011 at 9:58 AM

Another problem: I unpublished one of my modules, Service Validation Libraries. It correctly vanished from the public site and is listed under unpublished packages, but it's also there under my submissions. When I open it a YSOD comes up.

Coordinator
Dec 22, 2011 at 11:22 PM

If they don't exist yet, would you mind filing those issues on http://orchardgallery.codeplex.com/workitem/list/basic?

Developer
Dec 23, 2011 at 7:31 PM

I've opened issues here and here. Couldn't find any related ones.