imidiate autologout

Topics: Administration, Troubleshooting
Oct 30, 2011 at 1:31 PM

I have a fresh installation. After I login as admin it takes one click and I am redirected to the loginpage.

Orchard is not storing the logininformation.

Where can this be fixed?

 

Thanks a lot for your help.

Oct 30, 2011 at 3:47 PM

Can you check your log files to see if any errors are being generated? They're in App_Data/Logs

Oct 30, 2011 at 4:34 PM

Thanks for your reply.

the only entry I have is:

2011-10-30 01:18:56,972 [10] NHibernate.AdoNet.AbstractBatcher - Could not execute query: SELECT this_.Id as Id11_0_, this_.SerialNumber as SerialNu2_11_0_ FROM Settings_ShellDescriptorRecord this_ WHERE 1=1
System.Data.SqlServerCe.SqlCeException (0x80004005): The specified table does not exist. [ Settings_ShellDescriptorRecord ]
   at System.Data.SqlServerCe.SqlCeCommand.ProcessResults(Int32 hr)
   at System.Data.SqlServerCe.SqlCeCommand.CompileQueryPlan()
   at System.Data.SqlServerCe.SqlCeCommand.ExecuteCommand(CommandBehavior behavior, String method, ResultSetOptions options)
   at System.Data.SqlServerCe.SqlCeCommand.ExecuteDbDataReader(CommandBehavior behavior)
   at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()
   at NHibernate.AdoNet.AbstractBatcher.ExecuteReader(IDbCommand cmd)
2011-10-30 01:18:56,986 [10] NHibernate.Util.ADOExceptionReporter - The specified table does not exist. [ Settings_ShellDescriptorRecord ]
2011-10-30 01:18:56,991 [10] NHibernate.Util.ADOExceptionReporter - The specified table does not exist. [ Settings_ShellDescriptorRecord ]

 

 

which I believe is not connected to my problem. Is it a setting in the web.config? "persistant  connections" or anything like that?

Coordinator
Oct 30, 2011 at 9:47 PM

Make sure you have a machine key: http://orchardproject.net/docs/Setting-up-a-machine-key.ashx

Oct 31, 2011 at 6:49 AM
Edited Oct 31, 2011 at 6:51 AM

that was it! thanks a lot. could not find that. guess I have to work in the docu more.....

 

ps: can I "close" this thread or set to "answered" anywhere? Or at least give you a point? ;-)

Jun 21, 2012 at 11:02 PM

Hey.

Just wanted to share, I had the same issue but apparently it seem to have been caused by a column named Key.

Is Key a protected column name? if so i think there should be an exception when one try to use it.