CS0535: 'Lucene.Services.LuceneSearchBuilder' does not implement interface member 'Orchard.Indexing.ISearchBuilder.WithField(string, double)'

Topics: Installing Orchard
Oct 27, 2011 at 10:41 PM

I know there is another post about this error, and it has been resolved.  However, my case is different.

I have upgraded to 1.3 (I checked the files in folder Modules, and found they are dated 2011-10-03), but I still get the following error.  Could anyone shed some light on this?

  



Server Error in '/home' Application.

 


 

Compilation Error

Description:

An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0535: 'Lucene.Services.LuceneSearchBuilder' does not implement interface member 'Orchard.Indexing.ISearchBuilder.WithField(string, double)'

Source Error:

 
Line 13: 
Line 14: namespace Lucene.Services {
Line 15:     public class LuceneSearchBuilder : ISearchBuilder {
Line 16: 
Line 17:         private const int MaxResults = Int16.MaxValue;


Source File: c:\Web Apps\hzhang.org\home\Modules\Lucene\Services\LuceneSearchBuilder.cs Line: 15

Coordinator
Oct 27, 2011 at 11:55 PM

Apparently you did not upgade everything. You need the latest of Orchard itself, and also of all the modules.

Oct 28, 2011 at 12:09 AM

I followed the instructions to do the upgrade.  I don't know what else that I need to do.  More specificcally:

1. I used WPI to install an instance of Orchard 1.3.

2. Copy the existing site's Media folder into the new directory.

3. Copy the remaining module and themes directories that are on the existing site and that are not already in the new one into the new directory's Modules and Themes directories.

4. Copy the App_Data folder from the existing site into the new directory.

Do you see anything that I have missed?

Coordinator
Oct 28, 2011 at 12:14 AM

Yes: you did not install the latest versions of the modules. Lucene does not come with the default package from WPI.

Oct 28, 2011 at 12:58 AM

Could you tell me how to install the module when Orchard is not working?  I have downloaded Orchard.Module.Lucene-1.3.0.nupkg. 

Coordinator
Oct 28, 2011 at 1:13 AM

You will also need search and indexing modules. The easiest way to install on top of your broken instance should be to delete your existing lucene directory, which should restore the application back to working state and then re-install from the dashboard. If for any reason you can't do that, all you need to know is that nupckg files really are zips, so you can rename them .zip and then open them and drill into their directory structure to the module's directory, that you can then copy into the modules subfolder of your app.

Oct 28, 2011 at 2:04 AM

Hallelujah! I believe the nightmare has ended. Thank you!

Per your suggestion, I deleted folder Lucene, and the app worked instantly afterwards. The Modules page suggested installing Lucene and updating Blog and Page modules (very nice feature).  I did all three.  Now, the site is running.  What a relief. I will close another post by describing very briefly the pain that I have gone through.