This project is read-only.

SQL phantom connection (SOLVED)

Topics: General, Troubleshooting
Oct 26, 2011 at 12:29 PM

It's possible that Orchard could work with the data base server (SQL Server 2008 R2) paused?

I know it sounds strange but is what is happen to me, I was reading SQL Server docs, googling for a couple of  hours, looking at the logs and didn't get anything usefull. Of course cleaned my browsers cache and I considered that the web server was also caching the pages (I'm talking about three Orchard installs anda data bases) so I tried to edit and save the changes and all seem to be OK.

Included my boss is surprised by this. Thanks in advence for responses.

Oct 26, 2011 at 1:13 PM

Just a quick hint, could this be a result of the Warmup module?

Oct 27, 2011 at 8:50 AM

Hi Piedone,

thanks for your response. I tried what you say but not, Orchard is still working with the Warmup module disabled and his database detached. In fact I tested thye aplication with the database server paused (it means that isn´t pointing another database) and it's still alive an d I'm able to edit, save, delete and publish....

I don´t know what more can I test and I can understand how is possible that be running without any database, anyone have a sugestion?

Oct 27, 2011 at 9:05 AM

Wow, that's interesting for sure. Take a look at the Settings.txt in your site's App_Data folder (under Sites/Yoursite), there is the SQL server's connection string. It could be that it's still pointing to another server, maybe to testing.

Oct 27, 2011 at 9:32 AM
Edited Oct 27, 2011 at 9:37 AM

Mistery is cleared!

Finally it's was a server-side cache thing, that only refresh itself if I edit and re-publish a page. If I edit an Html widget content (that only provide a 'Save' button, not a 'Publish' one) it publish the new content without problems and that's the fact was confusing me. Also when I created a new page it save the changes and show me the new one...

I checked the Settings.txt file but there´s not connection string:

Name: Default
DataProvider: SqlCe
DataConnectionString: null
DataPrefix: null
RequestUrlHost: null
RequestUrlPrefix: null
State: Running

It sounds me that I might have a string instead 'null', isn´t it?

Anyway it works now, many thanks for your atention and sorry for my english, I know it´s a little bit 'chungo'.

Oct 27, 2011 at 11:18 PM

It's only that you're not using a separate SQL Server, but Compact. This is of course fine and there is no problem with your Settings.txt. But it's nice you've figured it out :-).

Oct 28, 2011 at 8:39 AM
Edited Oct 28, 2011 at 11:07 AM

I understand that's the main reason for my 'phantom' events, but.... the web site is on production now, so I need to be carefully about don't loose any data. We develope our aplications ever on SQL standard, so we need to keep all the data stored in the same way.

What it implies on backup tasks? Or, where can I find info about the better way to manage this configuration at the time of backup the site? Or still better, how can I change this?

I supose the connection string I provided at the installation step was not the correct one to use my standard SQL.

 In detail:

- What data provider have I to use to change from Compact to Standar SQL?

- What is the correct connection string in this case?

Thanks again.


I get it! it's so simple, I have to just open the web site in WebMatrix and hit 'Migrate'... en dos palabras: im prezionante!

Oct 28, 2011 at 11:33 AM
Edited Oct 28, 2011 at 11:36 AM

Conclusions or how do not develope with Orchard...

  • I installed Orchard on Visual Studio ('cause it's what is used in my job place and 'donde fueres haz lo que vieres')
  • First mistake: I choose SQL Compact for developement BUT installed fresh Orchard in the server pointing a SQL server standard
  • Second mistake: I copy the content of Orchard.Web folder on my desktop and replace the fresh Orchard's installation folder content

Anyway ther is one point that I can't understand at all: why yesterday Orchard failed (with a 404) when I edited pages but not when I edit widgets or created new pages? By now I have no idea why it happens, but I promise to post it here if I find the response.

Now, I know it's not the way and that the simpliest is to work whith Webmatrix or a well installed Orchard on a test server and then migrate it. I hope this discussion could be usefull for anyone starting on Orchard developement like me.

Thanks for patience, I know it's hard to deal with newbies.