This project is read-only.

Deleted blog post still appearing in blog list

Topics: Administration, General, Troubleshooting
Oct 17, 2011 at 8:56 PM

The blog list page:

And the post in question:

Here's the funny thing... that post doesn't exist, at least Orchard doesn't think so. In the shape tracer, it has an ID, but can't be found in the admin panel at all. Hitting Edit from the front-end hits a 404, specifying the ID in the url of the Edit Blog Post window also 404's. My solution was gonna be to pull down the DB, connect to it locally, find the bad record and wipe it, then push the DB back up, but SSMS is complaining about the DB being of the wrong type... tried installing CE 3.5 and 4.0 runtimes, and still no luck.

Anyone seen mystery content items like this that don't seem to exist according to Orchard, yet they continue to be displayed? No, it isn't cache.

Oct 18, 2011 at 5:31 PM

May it be a Draft version, which would not be visible unless authenticated ?

Oct 18, 2011 at 9:04 PM

Even in the admin panel, it isn't visible at all. Any attempt to edit a blog post with the phantom ID 404's, as I would've expected.

I guess one option would be deleting it manually out of the database, but as I said, I haven't been able to get SSMS to open the CE DB. Is there anything special that needs to be done for SSMS to work right with it?