This project is read-only.

Having Trouble with ClickToBuild and Orchard.Source using VS2010

Topics: Installing Orchard, Troubleshooting
Oct 7, 2011 at 1:12 PM
Edited Oct 7, 2011 at 1:15 PM

I had been playing around with Orchard 1.2 when I noticed (about a week later) that 1.3 was released. I downloaded Orchard.Source and have VS2010. I originally ran build on Orchard and Orchard.Web bloated to 600+MB. I then began reading about using ClickToBuild in order to get that down to ~50MB for deployment to a live server. Being that ClickToBuild was not part of the Orchard.Source, and having read that I could D/L it from "Source Code" here I picked the version that matched 1.3.  From that D/L I copied over "build.cmd", "ClickToBuild.cmd", "DeleteModuleBinaries.cmd" and "Orchard.proj".

When I run "ClickToBuild.cmd" (either by Administratively using the VS 2010 Command Prompt in the directory which contains the file, or by "Clicking" on it) I go through a lengthy (speedy) build process only to be met after about a minute or so with this "hang"



ProcessModel: Default   DomainUsage:Multiple

Execution Runtime: net-4.0.30319.237

TeamCity addin initializing...

TeamCity addin loaded

TeamCity addin installed

TeamCity addin initializing...

TeamCity addin loaded

TeamCity addin installed

TeamCity addin initializing...

TeamCity addin loaded

TeamCity addin installed

TeamCity addin initializing...

TeamCity addin loaded

TeamCity addin installed

TeamCity addin initializing...

TeamCity addin loaded

TeamCity addin installed


It then just "hangs" there, with no prompt, no results, nothing. I suspect I have the wrong files, or the procedure down wrong. There is not concrete documentation out there on deploying from VS2010, at least that works in my case.

What I am trying to do is figure out (and document for myself) my deploy strategy. I've not done much with modules, simply because I want to get this down before I start delving into module development. I had hoped to be able to get to the point where I have that ~50MB Orchard.Web to deploy, with the ability in the future to update it with new versions of Orchard or my modules.

My only other thought is to just work with Orchard.Web.1.3.9, and then do module development with a text editor (as one of the docs points out).

I have searched around for an answer, but everything is just jumbled up with certain things working for some and not for others. I fall into the "others" category. 

Appreciate any help.  Thanks.

Oct 7, 2011 at 7:21 PM

Yeah, ClickToBuild runs all tests, and for whatever reason it failed on your machine. There is a better way, which is to run "build package" from a VS prompt. This will result in a clean package in artifacts/msdeploy. What is in the package depends on what projects are included in the src/orchard.sln solution. I updated the developer FAQ to specify this.

Oct 10, 2011 at 9:25 PM

I just tried following "build package" guidelines to build live server and ran into missing assembly?


While loading Orchard getting following error

Could not load file or assembly 'Orchard.WarmupStarter, Version=1.0.20, Culture=neutral' or one of its dependencies. The system cannot find the file specified.

Am I missing anything here?




Oct 10, 2011 at 10:21 PM

Did you build first from VS?

Oct 10, 2011 at 10:39 PM

Yes, I did.

Oct 10, 2011 at 10:47 PM

Is the warmup module in the solution?

Oct 10, 2011 at 10:54 PM

Yes, it's there. I also tried running orchard from vs2010 and getting setup page.

Oct 10, 2011 at 11:03 PM

I don't know, when I do it, warmup definitely gets packaged with everything...

Oct 10, 2011 at 11:05 PM

Reading your first message, I think you need to download everything from the source code. For instance there are some specific msbuild tasks in it that are compiled during this process. So it's not just about getting a few script files.

Oct 11, 2011 at 12:50 AM

I've complete source code and it packages without any warning or errors. 

Oct 11, 2011 at 1:02 AM

And can you see the warmup module in the package?

Oct 11, 2011 at 3:24 AM

Yes. Its there in packaged zip file. As I said, I can run code fine in VS and gets me to Orchard setup screen. I'll get 1.3 source code zip again and give it a shot.

Oct 11, 2011 at 6:29 AM

got code from default branch and still getting same error. Definitely a bug. btw, 1.3 is not available on web gallery - Any ETA on when it'll be pushed out?

Oct 11, 2011 at 7:47 AM

Please file a bug with detailed repro steps then.

The web gallery folks have had the bits since last Monday. We're waiting for them to act on it.