This project is read-only.

Can not access any theme or media files unless logged in as an administrator

Topics: Installing Orchard, Troubleshooting
Oct 1, 2011 at 12:28 PM

I played around with permissions and in the end, could not access the CSS files anymore(not sure if related) so I did a clean installation on the same machine. Whenever I was not logged in as an administrator, I seem to not get the static files(images, css files and so on) that should be handled over me. I did a new installation and right from the beginning I had the same problem, even thought the permissions are right this time I think: Read/Write on everything inside the new website folder for user "IIS_...".

I am not very familiar with IIS and ASP.NET and I can not figure this thing out on my own. I am glad I found this site.

Styles folder has the default web.config file in it, and so do every other folder that has it. Whenever I try to access the file directly from the browser, I get the ASP.NET 404 error:

Server Error in '/' Application.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /Users/Account/AccessDenied

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.237

Can anyone please point me to the right direction of fixing it?

Oct 1, 2011 at 9:45 PM

It could be a number of things, such as read permissions on those directories for the user under which the IIS process is running.

Oct 3, 2011 at 2:04 PM

I have the same issue and I checked that my IIS user have all permissions to read those files. Any other clues?

Oct 3, 2011 at 2:17 PM

Ok, it didn't take long but i finally fixed it. 

Only thing I had to do was setting in my IIS Manager -> YourSite -> (switching to Features View) Authentication -> edit Anonymous Authentication -> Set to Application pool identity.

And i think you would have to set all permission to your Application pool identity (mine was Network Service)

And now it works.