VS 2010 publish

Topics: Troubleshooting
Sep 28, 2011 at 9:01 AM

Hi,

I've looked up forums and apparently there are people like me, having problems publishing orchard website with visual studio publish feature.

For testing purposes I've configured it to publish to local file system and publish fails. For diagnostic purposes I've made my build log verbosity to be very detailed. I'm kinda baffled with this output.

 

28.9.2011. 10:50:20:    Target "PipelineTransformPhase" in file "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\Web\Microsoft.Web.Publishing.targets" from project "C:\Projekti\Orchard\src\Orchard.Web\Orchard.Web.csproj" (target "PipelinePreDeployCopyAllFilesToOneFolder" depends on it):
28.9.2011. 10:50:20:        Building target "PipelineTransformPhase" completely.
28.9.2011. 10:50:20:        No input files were specified.
28.9.2011. 10:50:20:        Task "GetPublishingLocalizedString"
28.9.2011. 10:50:20:        GetPublishingLocalizedString: Publish Pipeline Transform Phase
28.9.2011. 10:50:20:        Done executing task "GetPublishingLocalizedString".
28.9.2011. 10:50:20:        Task "CallTarget"
28.9.2011. 10:50:20:        Done executing task "CallTarget".
28.9.2011. 10:50:20:        Done building target "PipelineTransformPhase" in project "Orchard.Web.csproj".
28.9.2011. 10:50:20:    Target "AutoParameterizationWebConfigConnectionStrings" skipped, due to false condition; ($(AutoParameterizationWebConfigConnectionStrings)) was evaluated as (false).
28.9.2011. 10:50:20:    Target "CustomCollectFiles" in project "C:\Projekti\Orchard\src\Orchard.Web\Orchard.Web.csproj" (target "CopyAllFilesToSingleFolderForPackage" depends on it):
28.9.2011. 10:50:24:    Done building project "Orchard.Web.csproj" -- FAILED.

 

Does this look familiar to anyone?

Coordinator
Sep 28, 2011 at 4:54 PM

Are you in Rekease mode ? The VS publishing feature only works in Release.

Sep 28, 2011 at 5:28 PM

Hi Sebastien,

unfortunately I am.

Coordinator
Sep 28, 2011 at 6:29 PM

What version are you using ?

Sep 28, 2011 at 10:29 PM

Orchard is 1.2.41

Visual studio is 2010 ver 10.0.30319

May 30, 2012 at 5:26 PM

Same here. 

Orchard 1.4.0.0

VS 10.0.40219.1 SP1Rel

Happens in Release and in Debug.

Fortunately, can deploy using WebMatrix.  WebMatrix also uses MSBuild, right? 

Coordinator
May 30, 2012 at 5:38 PM

Is there a bug open for this one ? Can you if not ?

Jun 6, 2012 at 4:57 PM

:s

Started working when I tried it yesterday, just for the sake of trying.   I'll sit and think what changes I have made to the solution, environment, etc and maybe try to replicate... Will post update if I can reproduce again.

Coordinator
Jun 6, 2012 at 5:12 PM

Thanks for the update.