ClickToBuildAzurePackage error

Topics: Installing Orchard, Troubleshooting
Sep 27, 2011 at 2:17 PM


I am trying to build an azure package with the ClickToBuildAzure script but I've got this error:

  C:\Users\sjoerd.van.der.meer\Documents\Orchard Default Build\lib\nunit\nunit-
  console.exe /nologo "C:\Users\sjoerd.van.der.meer\Documents\Orchard Default B
  ProcessModel: Default    DomainUsage: Single
  Execution Runtime: net-4.0.30319.225
  Could not load file or assembly 'Orchard.Azure.Tests' or one of its dependenc
  ies. The system cannot find the file specified.
C:\Users\sjoerd.van.der.meer\Documents\Orchard Default Build\AzurePackage.proj(
75,5): error MSB6006: "nunit-console.exe" exited with code -2.
Done Building Project "C:\Users\sjoerd.van.der.meer\Documents\Orchard Default B
uild\AzurePackage.proj" (Build target(s)) -- FAILED.

"C:\Users\sjoerd.van.der.meer\Documents\Orchard Default Build\AzurePackage.proj
" (Build target) (1) ->
(Test target) ->
  C:\Users\sjoerd.van.der.meer\Documents\Orchard Default Build\
j(75,5): error MSB6006: "nunit-console.exe" exited with code -2.
    0 Warning(s)
    1 Error(s)

I've had another issue before This is solved by using the 1.4 sdk.

What I've done:

  1. I First made a vm with w7 32 bit.
  2. Installed vs 2010 ultimate with all the updates
  3. Tried to install the 1.4 sdk with the link given at which is I used the first link with the VSCloudService.exe.
  4. Couldn't install because IIS 7 was missing. Installed it with WPI.
  5. Installed 1.4 sdk with the VSCloudService.exe
  6. I've cloned the default source as described at
  7. And after that I've ran ClickToBuildAzure.cmd from the visual studio commandprompt with administrator rights.
  8. Than I've got the error above.

Does anyone know a solution?

Thanks in advance


Sep 27, 2011 at 6:28 PM

Please use the lataest source code version, which is compatible with SDK 1.5. This will be released on Monday.

Sep 28, 2011 at 12:15 PM

Oke thanks.

Is there a way to build an Azure package at this moment as the current documentation is outdated?

Kind regards,


Sep 28, 2011 at 4:49 PM

USe the SDK 1.3 if you want to use current release.

Oct 13, 2011 at 1:10 AM

Sebastian/Orchard team:

Can you confirm that the Orchard 1.3 release is now compatible with the Azure 1.4 SDK & Tools, specifically the new ability to configure deployment options for different deployment targets?

Oct 13, 2011 at 5:05 AM

I confirm it's compatible with SDK 1.5 actually.

Oct 13, 2011 at 3:00 PM

Awesome. Thanks Sebastian :)

Nov 21, 2011 at 7:36 PM

I am getting somthing simmilar but more complicated I think. 


"C:\OrchardEnlistment\AzureOackage.proj" <Build target> <1> ->
<Test target> ->
  NUNIT : 1> SetUp error : Orchard.Azure.Tests.Environment.Configuration.AzureShellSettingsManagerTests [C:\OrchardEnlistment\AzurePackage.Proj]
  NUNIT : 1> SetUp error : Orchard.Azure.Tests.FileSystems.Media.AzureBlobStorageProviderTests [C:\OrchardEnlistment\AzurePackage.Proj]


Thank you

Nov 21, 2011 at 7:38 PM

Are you doing this from a visual studio or .net sdk command-prompt?

Nov 21, 2011 at 9:03 PM

Visiual Studio 2010

Nov 21, 2011 at 9:04 PM

Do you have the Azure SDK 1.5 installed?

Nov 21, 2011 at 9:06 PM


Nov 21, 2011 at 9:16 PM

That O in the package name seems suspect. there is no such project.