FluentNHibernate v2.x ??

Topics: Administration, General
Sep 14, 2011 at 2:45 PM

Is there any reason why Orchard is not using FluentNHibernate v2.x at a minimum ??  Currently, Orchard is using v1.0 and as a result, we are having problems connecting to a DB2 database (unless I am missing something).

Are there any plans to migrate to v2.x ???

 

Developer
Sep 14, 2011 at 4:21 PM

From my understanding it is not a trivial task to upgrade FluentNHibernate within Orchard, though I believe this will be done for Orchard v2, though the release Orchard v1.3 will not have this in.

Please see this issue for current comments on it http://orchard.codeplex.com/workitem/18020

Coordinator
Sep 14, 2011 at 5:15 PM

I believe this is already checked-in, but it has consequences on medium trust. We can't break medium trust in 1.x so we could either fix the library (and contribute the patch) or decide to remove medium trust compat from 2.0.

Developer
Sep 14, 2011 at 5:16 PM

Are ya sure? I thought that was the latest version of NHibernate?

Coordinator
Sep 14, 2011 at 5:18 PM

Right, but we want to upgrade all that at once.

Developer
Sep 14, 2011 at 5:20 PM

That I am not disputing.

Sep 14, 2011 at 5:21 PM

Actually, the latest version of NHibernate is 3.1 right now and FluentNHibernate is up to 1.2 (Orchard is using 1.0).

http://fluentnhibernate.org/