Possible problems with installation/Command-line troubles

Topics: Installing Orchard, Writing themes
Aug 12, 2011 at 11:58 PM

I have installed Orchard locally using the Web Platform Installer, and WebMatrix, v1.2.41, I chose the default options for the DB, etc.

WebMatrix opens, I run the site, Fill out the name of the site, passwords, etc.

I install the code generation tool, and i see that it's enabled under Modules>Features and also on the Installed tab.

I open a command line at the root of my local orchard project, navigate to bin\orchard.exe.

The ONLY command available to me is Setup. Why and how do I fix that? Based on the running site in my browser I'd say that orchard is already setup.

The documentation says this is the only command available until the setup is completed. What other steps do I need to take to be able to run additional command from the command line, mainly "codegen"?

Aug 17, 2011 at 9:52 PM

When you say "navigate to bin\orchard.exe", are you sitting in your Orchard.Web folder, and running the executable at bin\orchard.exe, or are your cd'ing into bin, then running orchard.exe?  It's subtle, but important.

As a side note, I find it really nice to utilize the Web Command Line feature.  Enable it in the modules admin, and navigate to http://yoursitenamehere.com/Experimental/Commands.  You can run commands the same as from the command line.  Might want to double check security on that though for a public site...

Aug 18, 2011 at 5:49 PM

Not sure what the deal was but I ended up starting over from scratch and everything worked as expected...

 

Weird!