Child Theme Does Not Change Background Color

Topics: Administration, Troubleshooting, Writing themes
Aug 12, 2011 at 5:18 PM

First, I would like to thank all the developers and Microsoft for creating a great cms application!!

I look forward to developing sites with this well designed application.

 

I am new to Orchard CMS, but I am an experienced ASP.Net developer. 

I followed the documentation to install the Orchard binaries using WebMatrix and everything went perfectly.

I then *carefully* followed the steps in the "Customizing Themes" documentation page to the letter and everything appeared to work fine.

However, when I go back to view the web pages, the background color is still white.

I have repeated a clean install of Orchard binaries and the Customizing Themes steps three times to make sure that I am not making a mistake.

I have also checked the folders and files and everything appears to be correct.

Please tell me what to do to make this work.

Thanks.

 

Coordinator
Aug 12, 2011 at 5:53 PM

You need to change the background-color element defined on line 116. It worked for me.

Aug 13, 2011 at 4:04 AM

Thanks a lot for your help Sébastien!  I should have looked around for another body style. 

Aug 13, 2011 at 5:33 AM

The background color displays correctly now.  Thanks again!

One thing that I ran into after editing the site.css file is that, using WebMatrix, I get an http 404 error unless I completely close the site and re-open it.

Stopping and/or restarting the site does not fix the problem.

Am I missing a step?

Also, after my original problem has been answered successfully, is there a way for me to tag this discussion as closed, like the DevExpress support forums?

Coordinator
Aug 13, 2011 at 4:24 PM

I am not aware of this webmatrix issue.

No, I don't think you can close a discussion on codeplex. We don't really matter as usually people can restart them or add some more comments.