Email Settings

Topics: Installing Orchard, Troubleshooting
Jul 20, 2011 at 3:43 PM

Please help me with my Email settings - I can't send Challenge Emails to the users.

Messaging and Email modules are installed, my SMTP Server is running  (IIS 6.0 to config) and it is setup to allow relay of 127.0.0.1, the SMTP server can send emails.

I have setup the Host Name to Localhost, 127.0.0.1, the IP of the server and nothing works. (Port = 25, SSL=no, Credentials=no)

Much appreciated.

 

Coordinator
Jul 21, 2011 at 5:39 PM

You can try to install SMTP4dev from codeplex, and use it as the SMTP server. It will show you if it is an issue due to Orchard itself. Otherwise, the issue is in IIS configuration. At least it might help to narrow the issue.

Jul 21, 2011 at 8:43 PM

You can also check your logs to see if it's throwing an error.  That said, I was having trouble getting the email working today (different issue) and was seeing weird behavior where sometimes it would get a helpful error, and other times it would silently fail and give me no feedback as to why.  

May 2, 2014 at 10:10 AM
I had the same issue:

Under Admin > Settings > Email, I input these configuration (I used gmail):

Sender Email Address: [sample]@gmail.com Host Name: smtp.gmail.com
Port Number: 587
I checked "Enable SSL communications"
My creditials are:
Username - [sample]@gmail.com Password - [myownpassword]

It is saved but no work. How to troubleshooting this problem?

There is no any error log in the log folder. Thanks.
Developer
May 2, 2014 at 11:34 AM
I manage to send mails with my gmail account.
I use the same informations you specified but with the port number : 25.

Which test do you try to send an email then?