PO file not processing accent marks

Topics: Localization
Editor
Jul 20, 2011 at 2:57 AM

For some reason my es-ES po file that I inserted in a module will not translate accent marks correctly. I am getting a display error on the front end:

Example:

Envíenos un mensaje. =

Env�enos un mensaj

 

The fr-FR po file I inserted in the module works fine with accent marks which is strange. I also cut and pasted new values for the strings to make sure there are no special characters hanging around. Any thoughts on where to look?

Coordinator
Jul 20, 2011 at 3:58 AM

Bad encoding. For example, if the file has been saved in UTF8 but without byte order marks (BOM), then when reading it, the encoding may be badly recognized, resulting in such charaters. Where does that po file come from?

Editor
Jul 20, 2011 at 9:58 AM
I copied them from another modules Localization directory and then modified. Perhaps I modified one incorrectly, because I just repeated the steps and saved in UTF-8 in notepad and all works.

Thanks for the hint!

On Tue, Jul 19, 2011 at 11:58 PM, bertrandleroy <notifications@codeplex.com> wrote:

From: bertrandleroy

Bad encoding. For example, if the file has been saved in UTF8 but without byte order marks (BOM), then when reading it, the encoding may be badly recognized, resulting in such charaters. Where does that po file come from?

Read the full discussion online.

To add a post to this discussion, reply to this email (orchard@discussions.codeplex.com)

To start a new discussion for this project, email orchard@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
Thanks,

Arra

Jul 20, 2011 at 5:38 PM
I really like to use Notepad++ for all kinds of encoding problems - it shows which encoding is used for the file and converts between 5 major encodings:

image.png

Cheers, Oliver
_____________


--- Eulers Identität ---



2011/7/20 arock3 <notifications@codeplex.com>

From: arock3

I copied them from another modules Localization directory and then modified. Perhaps I modified one incorrectly, because I just repeated the steps and saved in UTF-8 in notepad and all works.

Thanks for the hint!

On Tue, Jul 19, 2011 at 11:58 PM, bertrandleroy <notifications@codeplex.com> wrote:

From: bertrandleroy

Bad encoding. For example, if the file has been saved in UTF8 but without byte order marks (BOM), then when reading it, the encoding may be badly recognized, resulting in such charaters. Where does that po file come from?

Read the full discussion online.

To add a post to this discussion, reply to this email (orchard@discussions.codeplex.com)

To start a new discussion for this project, email orchard@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
Thanks,

Arra

Read the full discussion online.

To add a post to this discussion, reply to this email (orchard@discussions.codeplex.com)

To start a new discussion for this project, email orchard@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com