Loading Nuget.core error

Topics: Troubleshooting
Jul 18, 2011 at 8:41 PM

I have published working copy to my Host and I am getting the following error :

 

Could not load file or assembly 'NuGet.Core, Version=1.1.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Jul 19, 2011 at 6:14 PM

anybody has any ideas

Coordinator
Jul 19, 2011 at 7:18 PM

Do you have an old version of NuGet in the GAC?

Jul 19, 2011 at 8:12 PM

I have the following NuGet assemble in the GAC

Version = 1.0.11220.104

Runtime = 4.0.30319

 

Coordinator
Jul 19, 2011 at 9:06 PM

Can you verify you have Nuget.Core, v1.1.0.0 in the App_Data\Dependencies folders?

My guess is that what is happening is that instead of loading the assembly from "App_Data\Dependencies", the CLR is trying to load another version of nuget.core.dll from another location. The GAC is the most likely one, but it might be that you have a copy of Nuget.Code.dll in the "Bin" folder of the app, or that there is an assembly rebinding in web.config, or a publisher policy redirecting Nuget.Core 1.1 to some other version.

Following the instructions there might help diagnose the problem: http://blogs.msdn.com/b/suzcook/archive/2003/05/29/57120.aspx

HTH,

Renaud

Jul 21, 2011 at 8:30 PM

Thanks. I corrected the problem by adding reference to NuGet from App_Data\Dependencies folder.

 

I am running into another problem. I published the site to my host and everything working fine. The issue that I am having is when i try to compile it in visual studio 2010. It errors out when it compiles modules saying

 

"The type or namespace name 'AmazonCheckout' could not be found (are you missing a using directive or an assembly reference?) c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\4560eb12\3590e43e\App_Web_svn5akli.0.cs"

 

AmazonCheckout module happens to be my first module. Please advise


 

Coordinator
Jul 21, 2011 at 8:39 PM

You are probably missing the assembly reference in the project, as the error message says.

Jul 21, 2011 at 9:33 PM

There are lots of modules in the module folder but non of them have a bin directory. I don't see how to set the reference. I don't know where the dll are for these modules. Please advise

Thanks

Coordinator
Jul 22, 2011 at 12:01 AM

References are not set by dropping a dll into bin (you must be confusing this with web site projects). It is done by adding it to the project file for the module. From VS, right-click references and add reference.

Jul 22, 2011 at 9:02 PM

I understand that, but here is the problem. When you right-click and add a reference I need to have a dll to add into the project. I could not find any of the dll in the module folder. In this case something like 'AmazonCheckout.dll'.

 

Thanks

Coordinator
Jul 22, 2011 at 10:24 PM

You might want to contact the owners of that module: http://orchardproject.net/gallery/Package/ContactOwners/Orchard.Module.Amazon.Checkout

Jul 25, 2011 at 11:18 PM

There is something wrong with setting or configuration ??

This time I have created the new project from scratch using Webmatrix and Orchard CMS.

After I have installed Orchard CMS from the WebMatrix,  I clicked on visual studio 2010 button on top of WebMatrix and just tried to compile. First it gave a error saying reference is missing of 'Orchard.blogs' I added the reference then it started complaining about the following :

 

 

 Error 2 Object reference not set to an instance of an object. C:\Documents and Settings\himam\My Documents\My Web Sites\DezignerSarees\Modules\Orchard.Blogs\Orchard.Blogs.csproj 1

 

I have not modified anything or added anything. Just trying to compile out of the box ??. Very frustrating. Any help will be really appreciated.

 

Thanks

Coordinator
Jul 26, 2011 at 12:04 AM

You will have to choose between running the WebPI/WebMatrix version and letting the application compile modules dynamically on its own, or use the full source code and compile from Visual Studio.

Jul 26, 2011 at 3:09 PM

I want to use Visual Studio. Here is what I did :

I  opened  visual studio and open the project as a web site since there is no solution file and then tried to compile, I got the error what I mentioned above. What I am doing wrong ? Is there any setting I have to worry about. 

Thanks for your help. I liked the product and I want to use to develop e-commerce web site for my business.  I don't know it matters my day job is software development. I have been developing it for tthe last 10 years.

 

Thanks again

 

Coordinator
Jul 26, 2011 at 8:01 PM

Right, if you are going to use Visual Studio, please use the full source code and open the solution file.

Jul 26, 2011 at 9:31 PM

But there is no solution file. Do I have to convert it to have a solution file. ?

Coordinator
Jul 26, 2011 at 9:40 PM

There is no solution file because you did not download the full source code.

Jul 28, 2011 at 6:23 PM

Thanks. Now I understand how it works