Problem with Windows Live Writer 2011

Topics: Troubleshooting
Jul 17, 2011 at 8:17 AM

I have enabled XMLRPC and Remote Blog Publishing, but when I try to add the blog account I get the CHOSE BLOG TYPE window.

Can help ?

 

 

Coordinator
Jul 18, 2011 at 7:41 PM

Please follow the instruction in this article: http://orchardproject.net/docs/Blogging-with-LiveWriter.ashx

Jul 26, 2011 at 3:12 PM

I had same problems, the trick was to give "<MyblogURL>/blog" in first screen instead of just "<MyBlogURL>

Oct 30, 2011 at 8:58 PM

I have the same problem but adding /blog to the URL does not solve the problem.

It seems as if the automatic discovery of the publishing protocoll is not working ok.

Any other suggestions?

Coordinator
Nov 7, 2011 at 6:29 PM

I verified that just pointing LiveWriter to your blog works, so something else is going on here. If you see this problem, can you please use Fiddler to track the associated network activity?

Nov 8, 2011 at 1:34 PM

Hi,

I’ve just tried seeing what is going on with Fiddler. This is what I get in the log:

GET / HTTP/1.1
Accept: */*
Accept-Language: sv-SE, en-US, en, *
User-Agent: Mozilla/4.0 (compatible; MSIE 9.0; Windows NT 6.1; Windows Live Writer 1.0)
Host: ec2-46-137-48-16.eu-west-1.compute.amazonaws.com
Cache-Control: no-cache
Pragma: no-cache
Connection: Close


HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/html; charset=utf-8
Server: Microsoft-IIS/7.5
X-AspNetMvc-Version: 3.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Tue, 08 Nov 2011 14:31:26 GMT
Connection: close
Content-Length: 4722

<!DOCTYPE html>
<html lang="en" class="static ">
<head>
<meta charset="utf-8" />
<title>KBV.nu - Välkommen till Kontrollerad Bilverkstad!</title>
<link href="/Themes/KBV/Styles/Site.css" rel="stylesheet" type="text/css" />
<link href="/Modules/Orchard.Localization/Styles/orchard-localization-base.css" rel="stylesheet" type="text/css" />
<link href="/Themes/KBV/Styles/Site.css" rel="stylesheet" type="text/css" />
<meta content="Orchard" name="generator" />
<meta content="IE=edge,chrome=1" name="X-UA-Compatible" />
<link href="/modules/orchard.themes/Content/orchard.ico" rel="shortcut icon" type="image/x-icon" />
<link href="/Themes/SuperClassic/Styles/Alternates/default.css" rel="stylesheet" type="text/css" />
<link href="http://fonts.googleapis.com/css?family=Lobster&subset=latin" rel="stylesheet" type="text/css" />



</head>
<body>



<header id="layout-header" class="group">

</header>







<article class="content-item page">
<header>

Välkommen till Kontrollerad Bilverkstad!




okt 24 2011 10:08


</header>

Kontrollerad Bilverkstad ägs av Motorbranschens Riksförbund (MRF) och drivs som en märkesobeoreonde aktör. Fokus ligger på kundnytta, kvalitet och nöjda kunder. Oberoende Svensk Bilprovning svarar för kontrollerna. KBV följer centralt upp kvalitetsutvecklingen på sina anslutna verkstäder. I dag finns en unik databas över kvalitets- och kundnöjdhetsutvecklingen.


Kontrollerad Bilverkstad har skylten med den gröna punkten som symbol. Denna kvalitetsladdade symbol kan endast innehas av verkstäder anslutna till KBV.


</article>








<article class="widget-html-widget widget">
<header>

First Leader Aside



</header>


</article>



<article class="widget-html-widget widget">
<header>

Second Leader Aside



</header>


</article>



<article class="widget-html-widget widget">
<header>

Third Leader Aside



</header>


</article>







</body>
</html>


GET /images/public/teaser-2.jpg HTTP/1.1
Accept: */*
Accept-Language: sv-SE
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Zune 4.7)
Connection: Keep-Alive
If-Modified-Since: Mon, 17 Oct 2011 13:46:54 GMT
If-None-Match: "da25513bd38ccc1:0"
Host: kbv.nu


HTTP/1.1 304 Not Modified
Last-Modified: Mon, 17 Oct 2011 13:46:54 GMT
Accept-Ranges: bytes
ETag: "da25513bd38ccc1:0"
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Tue, 08 Nov 2011 14:31:26 GMT


GET /images/public/teaser-1.jpg HTTP/1.1
Accept: */*
Accept-Language: sv-SE
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Zune 4.7)
Connection: Keep-Alive
If-Modified-Since: Mon, 17 Oct 2011 13:46:54 GMT
If-None-Match: "95b03b3bd38ccc1:0"
Host: kbv.nu


HTTP/1.1 304 Not Modified
Last-Modified: Mon, 17 Oct 2011 13:46:54 GMT
Accept-Ranges: bytes
ETag: "95b03b3bd38ccc1:0"
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Tue, 08 Nov 2011 14:31:26 GMT


I am wondering if localization can be an issue? I’ve setup the blog to have Swedish (SV-se) as default locale. My LiveWriter is installed in Swedish…

When I add the account Live Writer is not able to detect the type of server.

My Orchard site is running in an Amazon IIS machine and it works fine.

/Joakim

Från: bertrandleroy [email removed]
Skickat: den 7 november 2011 20:30
Till: Joakim Westin
Ämne: Re: Problem with Windows Live Writer 2011 [orchard:265434]

From: bertrandleroy

I verified that just pointing LiveWriter to your blog works, so something else is going on here. If you see this problem, can you please use Fiddler to track the associated network activity?

Coordinator
Nov 8, 2011 at 6:44 PM

Oh, ok, that explains it. It's your theme. LiveWriter doesn't even go to the XMLRPC endpoint because your theme doesn't expose it. It's probably missing a @Display(Model.Head).

Thanks for the Fiddler trace.

(by the way, I had to reply via e-mail, because your post broke the CodePlex editor: you should have put this into a code block)

Nov 8, 2011 at 6:59 PM

Ok, that explains it.

But I used the Theme Machine theme… shouldn’t that use the proper @Display(Model.Head) ?

Sorry about missing the code block tags!

Cheers,

Joakim

Från: BertrandLeRoy [email removed]
Skickat: den 8 november 2011 20:45
Till: Joakim Westin
Ämne: Re: Problem with Windows Live Writer 2011 [orchard:265434]

From: BertrandLeRoy

Oh, ok, that explains it. It's your theme. LiveWriter doesn't even go to the XMLRPC endpoint because your theme doesn't expose it. It's probably missing a @Display(Model.Head).

Thanks for the Fiddler trace.

(by the way, I had to reply via e-mail, because your post broke the CodePlex editor: you should have put this into a code block)

Coordinator
Nov 8, 2011 at 7:06 PM

The theme machine doesn’t have a document.cshtml template, so it should just use the core one, which has it.

Another hypothesis of course is that you didn’t enable the feature…

(you should be able to edit your own post and remove most of that trace that is causing problems).