Folder Permissions

Topics: Installing Orchard
Jun 30, 2011 at 1:45 AM

Now that I have everything up and running (I am not using any db) what are the final permissions that need to be set to keep the site secure? Right now I had everything set User have full permissions on all the sites folders... thanks

Coordinator
Jun 30, 2011 at 1:54 AM
Edited Jun 30, 2011 at 1:54 AM

You need read permissions everywhere, and write permissions on app_data, media, and that's it unless you are going to install modules and themes, in which case you need write permissions on those too. That is all for the user under which the web server runs of course.

Jun 30, 2011 at 3:47 AM

Thank you... I have noticed that the worker process on the IIS is way up there... What are your recommendations using a db instead? What sort of impact would it have on the overall site load time? I wanted to stay static however, this may max out my memory soon...

Coordinator
Jun 30, 2011 at 3:58 AM

What do you mean "instead"?

Jun 30, 2011 at 4:26 AM

Okay--- I have been messing around tonight with both BLogEngine.Net and Orchard however, they both have the oprion of using their own "internal" databases versus an "external" MySQL or SQL db correct?

In other words, I did not install Orchard using either of the aforementioned databases... does this make sense or do I need to finally drift completely off to la-la land?

Coordinator
Jun 30, 2011 at 4:29 AM

Well, SqlCe may be storing its data file within the site's file system, but it is still a real database. You are of course going to get better performance out of the full SQL Server.

Jun 30, 2011 at 9:14 PM

Help me out here :?) it has been years since I worked with SQL... I installed Orcahrd via WebPI and the SQL Server 2008 R2 was installed however, I do not see any "tools" to create a new database in order to use the SQL server verses the SqlCE... My problem is that w3wp.exe "Orchard" process is using nearly 500k worth of memory and would like to shift the burden to the SQL server... I cannot even figure out scouring the net how to get into the SQL vvia the command prompt to create a database... I have found a plethora of information regarding the queries to execute however, from where is the big question now... thanks

Coordinator
Jun 30, 2011 at 9:26 PM

On those perf problems you're seeing, you are running in release mode, right?

Here is a video that show how to migrate to Sql Server: http://weblogs.asp.net/bleroy/archive/2011/04/14/migrating-an-orchard-site-from-sqlce-to-sql-express-using-webmatrix.aspx

Jun 30, 2011 at 11:57 PM

I have no idea what "release mode" is since, I installed it using Microsoft Wb PI on to IIS 7.5.... there must be a way to control the memory usage.... I ave set up cache for *.aspx and *.css (the latter was just a guess) hoping that i would being dishing out static pages...

Coordinator
Jul 1, 2011 at 12:03 AM

My own local instance, on Win7 and SqlCe, is using 115MB, so yes, there is something weird going on there. Caching will certainly use more memory (that's kind of the point, isn't it?). In the end, you don't know what is eating memory and you won't know until you attach a profiler to the server. Anything else will be shooting in the dark. Still, using SQL Server instead of SqlCe will definitely help with perf, as I said, so it's not wasted time on your part.

If you did not modify web.config from the WebPI package you are already in release mode.

Jul 1, 2011 at 12:32 AM

Um as far as the caching is concerned I meant disk caching however, it may be rough on the CPU... I tried the migration video... all appeared to go well with the migration at least to /SQLExpress however, at first I received an error message that I quickly released that I need to change the name of the default app pool back to ASP.NET 4.0... that brought the configuration page backup now, I am getting an error message stating "

Cannot open database "Orchard" requested by the login. The login failed. Login failed for user 'IIS APPPOOL\ASP.NET v4.0'."
As far as memory usage goes... my one site slowly crept up to around 375k with just the default post....
Any hints would be greatly appreciated... in the meantime, I really appreciate your assistance with this and will keep plugging away... the reason I am concerned (and I did notice on the video link you sent me, that he was seeing the same thing) I am having a sluggish "load time" with the site... I have a quad core XEON with 4 gigs of memory and plenty of bandwidth....
Coordinator
Jul 1, 2011 at 12:40 AM

You might want to edit the connection string in app_data/sites/default/settings.txt. There might be something wrong with it, or your Sql Server is not configured to accept that user login.

You should definitely not get that sort of perf on that hardware and configuration, even with SqlCe. Something sinister is definitely going on there. We might need to do some profiling here but in the meantime one thing you may want to check is whether you get any weird exception logs in app_data/logs.

Jul 1, 2011 at 1:05 AM

Have a look see at the site if you would not mind.... http://the.associated-news-network.com/

I went into the app pool settings and tried tweaking a bit...

(Recylcing events/triggers)

Isapi Reported Unhealthy TRUE

Private Memory Exceeded TRUE

Regular Time Interval True

Virtual Memory Exceeded TRUE

Set Virtual Memory limit to 100k

The above settings certainly have taken care of making certain my other sites not running Orchar do not suffer...

Thoughts?

Since I am on a hosted server, I will need to "rent" SQL as, I cannot get my copy up there to install...

 

Jul 1, 2011 at 1:59 AM

FYI - I just created a new site, without restrictions (I have enabled several modules which I will look at as possible suspects) however, the site is using 780k of the servers memory... I admit it is cooking right along by wow... that's seems rather resource intensive don't you think?

 

Coordinator
Jul 1, 2011 at 2:01 AM

If you mean 780MB then no, that's not normal, as I said before.

Jul 1, 2011 at 2:21 AM

OK -- 780M it is... I am just quoting what the Task manager is reading out... I am tweaking with the limits on this one, and began disabling modules, and went back to the default theme... is the the db (CE edition) causing this?

Jul 1, 2011 at 2:56 AM

I just changed the application pools to "Enable 32-Bit Applications and it appears to have some although still a little sluggish... what are your thoughts on using "Warmup" mode?

Coordinator
Jul 1, 2011 at 5:00 AM

It depends if most of the performance issues you're having are at startup from a cold app, it will help. Otherwise, it won't.

Jul 1, 2011 at 7:20 AM
Edited Jul 1, 2011 at 7:24 AM

FYI -- Under ASP.NET Pages and Controls... the Web.Config was throwing two errors (duplicate enteries on lines 103 and 104) I removed the duplicate namespafe references....

 Line 30:         <add namespace="System.Linq" />
 Line 103:         <add namespace="System.Linq" />

and I cannot remember what was duplicated on line 104...