This project is read-only.

Error Using Windows Live Writer to Publish Blog Posts with Pictures

Topics: Troubleshooting
Jun 29, 2011 at 4:10 PM


We can publish blog posts without pictures.  However, when we try to do one with a picture we have the following error:

Network Connection Error

Error attempting to connect to blog at:


Found: Found

Do I need to create a bug report for this?


Jun 29, 2011 at 7:46 PM

That is with what client? Windows Live Writer?

Jun 29, 2011 at 8:01 PM

Hi Bertrand,

Yes, we're attempting to use Live Writer to publish a blog post (with an image) when the error occurs.  We are able to publish text-only blog posts without a problem.



Jun 29, 2011 at 8:03 PM

Ah, sorry, I missed the hint in the title...

Yes, three things you can do: check the permissions on the media folder, check for a stack trace in app_data/logs and if you don't find any more info from that, attach a network trace tool such as Fiddler so that we can get a full error message.

Jun 30, 2011 at 3:04 PM

Hi Bertand,

Thank you for the information.  :)  It really helped me have an idea about what was wrong.  I checked the permissions on the folder and it was set to allow the user that our app pool is running as to have enough permissions.  However, when I used fiddler I saw that it was still having an access denied error.  Then I realized that I had turned on impersonation in IIS.  I turned it off for the Orchard virtual directory and it's working now.  

If it's possible, maybe Orchard should be modified to return a more informational error message to the client so that others having this problem will have an easier time finding a solution.

Thanks again for your assistance,


Jun 30, 2011 at 7:24 PM

Unfortunately, Live Writer swallows most of it anyways.

Aug 21, 2013 at 2:28 PM
I had problems setting up LiveWriter with Orchard at all, but finally managed to link them. However, I get a '500 Internal Server Error' when trying to publish posts which contain pictures.
I've prepared a pdf doc with setup information, some screenshots, a detailed error description and links to the fiddler output and server error logs.
If more information is required just tell me what you need.

Thanks in advance!
Aug 21, 2013 at 11:28 PM
can you try with 1.x, it should be fixed there now
Aug 22, 2013 at 8:28 AM
sebastienros wrote:
can you try with 1.x, it should be fixed there now
I'm using 1.7 already, shall I downgrade to 1.6? Or do you mean something else?

Aug 22, 2013 at 8:31 AM
He means the latest 1.x branch directly from Git, or from a download from the source tab of CodePlex, not 1.7.
Aug 22, 2013 at 3:46 PM
Edited Aug 24, 2013 at 11:28 AM
Thanks for clarification.
I've downloaded and installed the latest commit (5e0c26f73cf5052c51db835bec70f701f4246165) but the error is still exactly the same?
However, now I've got duplicate navigation links in the MainMenu and a 404 on the root / directory - shall I try to restore the backup of the old site and live without picture upload or do you have any other advice?


EDIT: I was able to fix the duplicate navbar thing: it somehow cooked the default recipe again and created duplicate widget layers + added widgets multiple times to each layer which was quite easy to fix once discovered.
However, the problem with the picture upload is still the same!
Sep 5, 2013 at 9:25 AM

I have exactly the same issue.
I had used an old version of Orchard CMS before, used Live Writer which found its settings automatically, could publish posts with pictures.

Now I've created a new site using Orchard 1.7, Live Writer doesn't find the settings automatically anymore, used http://mydomain/XmlRpc to connect.

I can publish post without images. Post with images raise the same error as above.

IIS Impersonation is disabled, app_pool account has full control rights over media folder.

I'd appreciate any help

Sep 6, 2013 at 1:31 AM
Did you try with the latest in the 1.x branch, as suggested above?
Sep 9, 2013 at 7:13 PM
@Carsten: I'd also like to know if it worked for you with the latest branch
@Bertrand: Have you changed anything in the meanwhile so that I should try an upgrade with the latest version again?

Sep 10, 2013 at 2:26 AM
I haven't but I think Sébastien has fixed it, yes.
Sep 10, 2013 at 8:54 AM
BertrandLeRoy wrote:
I haven't but I think Sébastien has fixed it, yes.
I can confirm: with the latest 1.x branch it's working like a charm, Thanks a lot!