WarmupHttp Object reference not set to an instance of an object

Topics: Writing modules
Jun 26, 2011 at 5:45 PM

Hi i'm getting the following error when i'm trying to debug my orchard instance from Visual studio 2010:

{"Object reference not set to an instance of an object."}

at System.Web.HttpApplication.AsyncEventExecutionStep.OnAsyncEventCompletion(IAsyncResult ar)
   at Orchard.WarmupStarter.WarmupHttpModule.WarmupAsyncResult.Completed() in d:\TeamCity\Projects\Orchard-Default\src\Orchard.Startup\WarmupHttpModule.cs:line 111
   at Orchard.WarmupStarter.WarmupHttpModule.SignalWarmupDone() in d:\TeamCity\Projects\Orchard-Default\src\Orchard.Startup\WarmupHttpModule.cs:line 52
   at Orchard.WarmupStarter.Starter`1.<>c__DisplayClass3.<LaunchStartupThread>b__2(Object state) in d:\TeamCity\Projects\Orchard-Default\src\Orchard.Startup\Starter.cs:line 100
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

followed by the following error on the page:

Operation could destabilize the runtime.

Has someone an clue how to fix this so i can start debugging again? Thanks!


 


Jul 14, 2011 at 7:14 PM

Someone has a clue?

Coordinator
Jul 14, 2011 at 7:21 PM

Are you getting any exception when you don't debug?

Jul 14, 2011 at 7:30 PM

No only in debug mode with visual studio 2010

Coordinator
Jul 14, 2011 at 7:45 PM

Are you getting it every time, and are you breaking on all exceptions?

Jul 14, 2011 at 7:55 PM

Yes i get it every time i run it in debug mode with Visual Studio. Without debug it runs fine.

Coordinator
Jul 14, 2011 at 11:29 PM

Assuming you are using Orchard 1.2 and VS 2010 SP1, can you try switching the web server to IIS Express and see if it solves the problem?

Jul 16, 2011 at 5:42 PM

I'm using Orchard.Web.1.2.41 and indeed VS 2010 SP1. Unfortunaly switching to IIS Express didn't help. And i still got the same error. Any suggestions?

Jul 18, 2011 at 1:16 AM

I get this error when Intellitrace is enabled.  Do you have intellitrace enabled and does it stop if you disable intellitrace?

Jul 18, 2011 at 6:08 PM

FIXED

@mattdotson Thank you for your reply! that fixed my problem. It works indeed when i turn off intellitrace. Is there already an real fix of bug report for this problem?