Installation Issue

Topics: Installing Orchard
Jun 26, 2011 at 1:45 PM

After running Web Platform Installer 3.0 to install Orchard (My instance of Orchard is named WSMJAC)  I initially had things working as listed below with code 302

2011-06-25 22:06:39 ::1 GET /WSMJAC/ - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+WOW64;+Trident/5.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+.NET4.0C;+InfoPath.3;+.NET4.0E) 302 0 0 8353

Then somehow things went wrong and I now get the following in the IIS Log File:

2011-06-25 22:06:39 ::1 GET /WSMJAC/Users/Account/AccessDenied ReturnUrl=%2fWSMJAC%2f 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+WOW64;+Trident/5.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+.NET4.0C;+InfoPath.3;+.NET4.0E) 401 2 5 5
2011-06-25 22:06:39 ::1 GET /WSMJAC/Users/Account/AccessDenied ReturnUrl=%2fWSMJAC%2f 80 DELLRED\Gary ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+WOW64;+Trident/5.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+.NET4.0C;+InfoPath.3;+.NET4.0E) 404 0 0 445

I have assigned write permisions to the IIS Users group to no avail.

Is this a permissions issue (401 error code suggests so) or could it be something to do with SQL Server 2008 R2.   Here is the error screen within IIS:

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /WSMJAC/Users/Account/AccessDenied


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1



Any pointers would be most appreciated

Jun 26, 2011 at 1:46 PM

Sorry, forgot to say that I was expecting the requested URL to be just /WSMJAC/

 

Jun 26, 2011 at 2:37 PM

SOLUTION

Not sure how this happened but within IIS (Authentication) both Forms Authentication and Windows Authentication were enabled.  By disabling Forms Authentication allowed me to proceed to he next step (Get Started).

Hope this helps someone.

Dec 14, 2012 at 4:01 PM
Gaztop63 wrote:

SOLUTION

Not sure how this happened but within IIS (Authentication) both Forms Authentication and Windows Authentication were enabled.  By disabling Forms Authentication allowed me to proceed to he next step (Get Started).

Hope this helps someone.

You Sir are a gentleman and a scholar. 
I give you a little star: *