Can't run Web Commands on tenant

Topics: Installing Orchard, Troubleshooting
Jun 24, 2011 at 5:16 PM
Edited Jun 24, 2011 at 5:17 PM


I'm running a multi-tenant site at Azure and just upgraded from 1.0 to 1.2. Following the docs, I enabled Experimental and Web Command Line. On the default site, I was able to browse to Experimental/Commands and "feature enable Orchard.Recipes"

On the tenant site, I enabled the same modules, but when I browse to Experimental/Commands I get an Unauthorized error. I am the super user.

Does Recipes need to be enabled on the tenant sites? Is there a workaround?


Jun 24, 2011 at 6:48 PM

It depends if you want to use anything that requires recipes :) For the moment, the module gallery (but you don't need that on Azure) and import/export, as well as setup (but you don't need that anymore).

Very weird that you're getting an unauthorized error. Alternatively you can try to add this module and enable it to enable recipes:

Jun 24, 2011 at 7:18 PM

Check out \src\Orchard.Web\Modules\Orchard.Experimental\Controllers\CommandsController.cs Execute()

if (_shellSettings.Name != ShellSettings.DefaultName || !Services.Authorizer.Authorize(StandardPermissions.SiteOwner, T("Not authorized to use the web console")))
                return new HttpUnauthorizedResult();

Hg Annotate shows "Andre Rodrigues @4950 '#17322 Restricting access to webconsole to default tenant'"

I would like to be able to import/export so that I can have a proper staging instance. I'll check out that module.

Jun 25, 2011 at 10:46 AM

That Upgrade.From.1.0 module did the trick. Thanks!