sqlce Migrate

Topics: Troubleshooting
Jun 22, 2011 at 10:06 PM

I have attempted to migrate the SQLCE db to SQLExp2008 on local server and to SQLExp2005 on VPS

Each time it fails on running the script, is there a way I find the script to examine the issue. I have found a couple of posts suggesting it works very well - but this doesn't actually help me! (I have seen the video and it looks great there !

Help appreciated

Mike

Coordinator
Jun 22, 2011 at 10:19 PM

Aren't you getting an error message?

Jun 22, 2011 at 11:05 PM
Edited Jun 22, 2011 at 11:13 PM

The notice is a simple 'failure' and it refers to line beginning "INSERT INTO.." - I think there is a line number but the message is obscured.

I am assuming its a sql error, but I dont know where the sql file is !!

thanks Bertrand - great work there !!

Just managed to find the error: not an orchard error but certainly stops me dead !!

---------------------------

Migration failed

---------------------------

Migration failed

 

An error occurred during execution of the database script. The error occurred between the following lines of the script: "62" and "72". The verbose log might have more information about the error. The command started with the following:

"INSERT INTO [dbo].[Common_BodyPartRecord]([Id],[Co"

 

---------------------------

OK

---------------------------

 

---------------------------

Microsoft.Web.Deployment.DeploymentException: An error occurred during execution of the database script. The error occurred between the following lines of the script: "62" and "72". The verbose log might have more information about the error. The command started with the following:

"INSERT INTO [dbo].[Common_BodyPartRecord]([Id],[Co"

---> ManagedBatchParser.ParserException

   at ManagedBatchParser.Parser.Parse()

   at Microsoft.Web.Deployment.SqlBatchParser.ProcessSqlCmdScript(String sqlCmdScript)

   at Microsoft.Web.Deployment.SqlScriptToDBProvider.AddHelper(DeploymentObject source, Boolean whatIf)

   --- End of inner exception stack trace ---

   at Microsoft.Web.Deployment.SqlScriptToDBProvider.AddHelper(DeploymentObject source, Boolean whatIf)

   at Microsoft.Web.Deployment.SqlScriptToDBProvider.Add(DeploymentObject source, Boolean whatIf)

   at Microsoft.Web.Deployment.DeploymentObject.AddChild(DeploymentObject source, Int32 position, DeploymentSyncContext syncContext)

   at Microsoft.Web.Deployment.DeploymentSyncContext.HandleAddChild(DeploymentObject destParent, DeploymentObject sourceObject, Int32 position)

   at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source)

   at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildren(DeploymentObject dest, DeploymentObject source)

   at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildrenOrder(DeploymentObject dest, DeploymentObject source)

   at Microsoft.Web.Deployment.DeploymentSyncContext.SyncChildren(DeploymentObject dest, DeploymentObject source)

   at Microsoft.Web.Deployment.DeploymentSyncContext.ProcessSync(DeploymentObject destinationObject, DeploymentObject sourceObject)

   at Microsoft.Web.Deployment.DeploymentObject.SyncToInternal(DeploymentObject destObject, DeploymentSyncOptions syncOptions, PayloadTable payloadTable, ContentRootTable contentRootTable)

   at Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentProviderOptions providerOptions, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)

   at Microsoft.Web.Deployment.DeploymentObject.SyncTo(String provider, String path, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)

   at Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentWellKnownProvider provider, String path, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)

   at Microsoft.WebMatrix.DatabaseManager.Client.SqlCeHelper.<>c__DisplayClass6.<StartMigrate>b__5(Object sender, DoWorkEventArgs eventArgs)

   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)

   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

---------------------------

Coordinator
Jun 22, 2011 at 11:22 PM

Weird. Two things we can do:

1. take this to the WebMatrix forums/bug reporting so they know about this issue and can figure out what's wrong.

2. do the migration with another tool. Can you try to install http://sqlcetoolbox.codeplex.com/ or http://exportsqlce.codeplex.com/ and use that to extract the data and move it to SQL Server? Then you can change you settings.txt in App_Data to use the connection string to the new database. This is what WebMatrix is essentially doing, but it's a more manual process.

Jun 23, 2011 at 12:41 AM

will do, thanks

Jun 23, 2011 at 11:15 AM

I have found that using jquery in a widget caused an issue - I used cycle and whilst it was working well, the whole orchard/webmatrix was creaking at the seams and failing at the edges.

Thanks again, I will advance a little further now :)

Coordinator
Jun 23, 2011 at 11:00 PM

That sounds a little off-topic and extremely vague. Can you tell me more about what issue is being caused and how?

Jun 24, 2011 at 9:56 AM

I used a jquery cycle in the content (much like in the Contoso Theme)

In case it was my own code I have retested with the simplest demo from jquery.cycle website and it has exactly the same effect !

______________________________________________

<script type="text/javascript" src="http://cloud.github.com/downloads/malsup/cycle/jquery.cycle.all.latest.js"></script>

<script type="text/javascript">

$(document).ready(function() {

$('.slideshow').cycle({

fx: 'fade' // choose your transition type, ex: fade, scrollUp, shuffle, etc...

});

});

</script>

<div class="slideshow">

<img src="http://cloud.github.com/downloads/malsup/cycle/beach1.jpg" width="200" height="200" />

<img src="http://cloud.github.com/downloads/malsup/cycle/beach2.jpg" width="200" height="200" />

<img src="http://cloud.github.com/downloads/malsup/cycle/beach3.jpg" width="200" height="200" />

<img src="http://cloud.github.com/downloads/malsup/cycle/beach4.jpg" width="200" height="200" />

<img src="http://cloud.github.com/downloads/malsup/cycle/beach5.jpg" width="200" height="200" />

</div>

______________________________________________

This works happily in the page header but breaks the Migration in WebMatrix and the also the Designer Tools in Orchard

I became initially aware with Designer Tools on Win7_64bit and thought this was the cause - as the tools works on Win7_32bit. I then discovered the Migration issue on the 32bit when I attempted publishing locally. I removed the code and it worked, returned to 64bit, removed again – and the designer now worked there.

Hope this helps you as certainly your reply helped me persist when I thought things were slowly falling apart !

Mike