Error trying to install "Vandelay.Classy" module

Topics: Troubleshooting
Jun 17, 2011 at 5:02 PM
Edited Jun 17, 2011 at 5:08 PM

 

Hi there,
I'm new to Orchard (just installed it this morning) and I just tried to install the "Vandelay.Classy" module by searching for it in the "Gallery" under "Modules" and then clicking "Install". I'm getting the following error however:

 Package installation failed.
 There was an error installing the requested package. This can happen if the server does not have write access to the '~/Modules' or '~/Themes' folder of the web site. If the site is running in shared hosted environement,  adding write access to these folders sometimes needs to be done manually through the Hoster control panel. Once Themes and Modules have been installed, it is recommended to remove write access to these folders.
 Input string was not in a correct format.

I assume it's the last line that's causing the problem since security isn't the issue. This is installed on my local machine and I tried giving full security access to "Everyone". The problem persists however. Can anyone assist? If not, all I'm trying to do is find out how to use CSS to style my page content so I can make any tweaks where required. If someone can point me to an article on how to do this it would be appreciated (I was investigating this module to see what it offers in this area). Thanks.
Coordinator
Jun 17, 2011 at 5:13 PM

What happens if you try to install another module?

Jun 17, 2011 at 5:58 PM

Thanks for the response. Should have thought of it myself (too many issues on the go). Am getting the same problem in fact. It can't be a security issue however, as previously noted. Any suggestions? Thanks.

Coordinator
Jun 17, 2011 at 6:00 PM

It can still be a security issue. You might have read only on that directory, or you might have missed something in the security settings, etc.

Jun 17, 2011 at 6:10 PM

I've given "Everyone" full rights to the folder. I have no problem accessing it under a normal user account. Note that I'm intimately familiar with Windows security (am an experienced C++ developer). I'm going to install this on another machine and see what happens. Will get back to you. In the meantime, are you able to point me to any links on how to deal with CSS (assuming I can't get this working). Thanks very much (appreciated).

Coordinator
Jun 17, 2011 at 6:18 PM

Well, I'm sure we can find what's wrong here, I was just verifying the most common causes first. If you are familiar with Windows security then you should probably turn on auditing on that directory so we can have more info on what's failing. You can also check in App_Data/logs to see if you can find a full stack trace corresponding to this.

Also, to get you unblocked for now, one thing you can do is download the package from the gallery manually, then rename it with a .zip extension. If you open it, you'll see a Content directory, and a Modules directory under that. In that Modules directory is the code for the module that you can copy directly under your own Modules in your site. That is equivalent to installing the module. You'll need to go and enable the feature yourself.

Jun 17, 2011 at 6:31 PM

Ok, thanks for the info. I'll be trying this out on another machine shortly. If that doesn't work I'll dig into the security situation a little further. Anything's possible of course but I've (temporarily) given "Everyone" full access rights to the entire "Users" folder (and all children). That group is present in all access tokens so in theory it should have eliminated any security problem (assuming it's a security problem in the file system itself). I'll keep you posted but it may not be until Monday at this point. Thanks again for your help.

Jun 17, 2011 at 6:46 PM

I just tried it on an XP Pro machine and it works fine. Presumably its an issue in my Win 7 Pro environment. I'll see if I can unravel it and get back to you by Monday. Thanks.

Jun 17, 2011 at 7:48 PM
Edited Jun 17, 2011 at 7:49 PM

Just a final follow-up. I can't find any obvious reason for the problem after running a few experiments but I did turn on auditing after applying an appropriate SACL to the entire folder (and all its children). I still can't find any errors that seem to be related to the problem (checked the event log up and down). If it is a security issue then it's not readily apparent. It's unclear what the final line of the message means though, i.e., "The Input string was not in a correct format". It's certainly suspicious and someone should probably investigate it. In any case, I installed it manually as per your previous post and it now shows up (I also enabled it) . Thanks again for your help. Greatly appreciated.

Coordinator
Jun 17, 2011 at 7:51 PM

Well, investigating it is pretty much what we're doing here. The problem is that I have no repro of it here (including on Win 7). Can you give more information about your configuration? Do you have a full stack trace?

Jun 17, 2011 at 8:00 PM

I apologize, you did ask me to check that. Would have saved us both some time. Here's the trace itself:

System.FormatException: Input string was not in a correct format.   at System.Version.VersionResult.SetFailure(ParseFailureKind failure, String argument)   at System.Version.TryParseComponent(String component, String componentName, VersionResult& result, Int32& parsedComponent)   at System.Version.TryParseVersion(String version, VersionResult& result)   at System.Version.Parse(String input)   at Orchard.Packaging.Services.ExtensionReferenceRepository.<GetPackages>b__4(<>f__AnonymousType2`2 <>h__TransparentIdentifier0)   at System.Linq.Enumerable.<>c__DisplayClass12`3.<CombineSelectors>b__11(TSource x)   at System.Linq.Enumerable.<>c__DisplayClass12`3.<CombineSelectors>b__11(TSource x)   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()   at System.Linq.Enumerable.WhereEnumerableIterator`1.MoveNext()   at System.Linq.Buffer`1..ctor(IEnumerable`1 source)   at System.Linq.OrderedEnumerable`1.<GetEnumerator>d__0.MoveNext()   at System.Linq.Buffer`1..ctor(IEnumerable`1 source)   at System.Linq.OrderedEnumerable`1.<GetEnumerator>d__0.MoveNext()   at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source)   at NuGet.PackageRepositoryExtensions.FindPackage(IPackageRepository repository, String packageId, Version version)   at NuGet.PackageRepositoryExtensions.FindPackage(IPackageRepository repository, String packageId)   at NuGet.ProjectInstallWalker.OnBeforeDependencyWalk(IPackage package)   at NuGet.PackageWalker.Walk(IPackage package)   at NuGet.InstallWalker.ResolveOperations(IPackage package)   at NuGet.ProjectManager.Execute(IPackage package, IPackageOperationResolver resolver)   at NuGet.ProjectManager.AddPackageReference(IPackage package, Boolean ignoreDependencies)   at NuGet.ProjectManager.AddPackageReference(String packageId, Version version, Boolean ignoreDependencies)   at NuGet.ProjectManager.AddPackageReference(String packageId, Version version)   at Orchard.Packaging.Services.PackageInstaller.ExecuteInstall(IPackage package, IPackageRepository packageRepository, String sourceLocation, String targetPath)   at Orchard.Packaging.Services.PackageInstaller.InstallPackage(IPackage package, IPackageRepository packageRepository, String location, String applicationPath)   at Orchard.Packaging.Services.PackageInstaller.Install(String packageId, String version, String location, String applicationPath)   at Orchard.Packaging.Services.PackageManager.<>c__DisplayClass8.<Install>b__7()   at Orchard.Packaging.Services.PackageManager.DoInstall(Func`1 installer)   --- End of inner exception stack trace ---   at Orchard.Packaging.Services.PackageManager.DoInstall(Func`1 installer)   at Orchard.Packaging.Services.PackageManager.Install(String packageId, String version, String location, String applicationPath)   at Orchard.Packaging.Controllers.PackagingServicesController.InstallGallery(String packageId, String version, Int32 sourceId, String redirectUrl)

Note that I have to run now unfortunately. I can pick this up again if you have any additional questions. Probably won't be today but as soon as I can (by Monday if not sooner).

Jul 7, 2011 at 3:14 AM

Just wondering if there has been any followups on this. I am actually getting the same issue. Was installing themes/modules just fine yesterday and now out of nowhere today I am getting this same error. Did try a reboot of the server and it didn't change anything, I am running the server on WHS 2011. 

Coordinator
Jul 7, 2011 at 10:10 PM

I'm sorry, I need to find some time to upgrade those modules. Please give me a few days.

Jul 8, 2011 at 2:34 AM

No worries. As long as there is a solution coming :)