This project is read-only.

The specified table does not exist. [ Settings_ShellDescriptorRecord ]

Topics: General
Jun 9, 2011 at 1:51 PM

Dear Team,

                I have encounter many times while starting the orchard project. The issue get resolved After restarting. but many times i get the same error can anybody point out the exact reason of this particular issue.


The specified table does not exist. [ Settings_ShellDescriptorRecord ]

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlServerCe.SqlCeException: The specified table does not exist. [ Settings_ShellDescriptorRecord ]



Mourice Fargose


Jun 9, 2011 at 1:58 PM

I usually see this error if I've deleted the database but not the App_Data/Sites folder.

Jun 9, 2011 at 2:04 PM

I didn't get you how to resolve this. and whats the specific reason for this. i am not deleting any thing.


Jun 9, 2011 at 2:30 PM

Must be a different reason then; I'm really not sure. Do you get this with a clean Orchard install or is it only with other modules installed?

Jun 9, 2011 at 3:04 PM
Ya other modules are also installed.

On Thu, Jun 9, 2011 at 7:00 PM, randompete <> wrote:

From: randompete

Must be a different reason then; I'm really not sure. Do you get this with a clean Orchard install or is it only with other modules installed?

Read the full discussion online.

To add a post to this discussion, reply to this email (

To start a new discussion for this project, email

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at

Jun 9, 2011 at 3:14 PM

Can you list those modules? Or see if after starting with a clean install, adding modules one by one gets you in the same situation again ?

Jun 9, 2011 at 3:32 PM

Dear Sharpoverride,

                             I am getting this error at random time i cant exactly point out when this happens. sometimes it works fine sometimes i am getting this error. Sorry i cant list out those as i have total 75 modules in my project.

Jun 9, 2011 at 3:44 PM
Edited Jun 9, 2011 at 6:41 PM

That's a lot of modules! I don't have that many in my install, and I'm working on three large projects simultaneously, each of which consists of a number of individual modules.

It's very likely that one of those modules is causing problems; or perhaps two modules are conflicting; or perhaps even Orchard is just falling over with that much going on (although it shouldn't be).

There's not really any way anybody can help you if you don't list which modules you have, or unless you test each module one at a time to find the culprit, as sharpoverride has suggested. Sorry - the error you've given is thrown from a core Orchard component, and we can't tell what module might be causing it if you don't debug the problem a little.

Which version of Orchard are you using? You might want to try updating to 1.2RC - it has much better performance and will handle 75 modules somewhat better.

Jun 9, 2011 at 3:56 PM

I am currently using version 1 but will go for 1.2 and will see. Thanx for response

Jun 9, 2011 at 4:15 PM

Ah, that'll be the problem - you should at least upgrade to 1.1, a lot of bugs have been fixed and newer modules might be incompatible with 1.0.

Oct 27, 2011 at 3:39 PM

I got this error today with 1.3. Tried to reproduce it, but the results were not exact the same.
When setting up a new webste with a recipe, my recipe contained

  <Module packageId="Orchard.Module.Vandelay.TranslationManager" />
  <Module packageId="Orchard.Module.Vandelay.Industries" />

The TranslationManager is also inside the Industries module, so that is a conflicting setup.

After removing the first entry the setup completed succesfully. I tried again with the conflicting setup, got the same message in the browser (request timed out), but no logging this time. Mayby log4net did not get a chance to flush to the logfile.

Oct 27, 2011 at 6:45 PM

The features other first are now included in the second, so you must remove the first.

Jan 9, 2012 at 3:43 AM
Edited Jan 11, 2012 at 12:28 AM


Regarding this "table [Settings_ShellDescriptorRecord] does not exist," I just experienced the same problem.  Strangely it was occurring only on my hosting provider, but was not occuring on my local box.  At first I thought this was caused by a manual edit to an installed module's table schema (I expanded an nvarchar column from 255 to 2048).  Having changed that one schema type, and then publishing to my host, that is when the problem started.  I then reversed what I had done to the database and published again.  The problem persisted.  I then tried disabling the module that is related to the table schema I had touched.  It disabled fine, but the next upload showed the problem would not go away.

Finally I did another "publish" to my host that fixed the problem - the only change I made was to select the option to "delete files on the remote server that are not on my computer."  Having done that, the problem was suddenly fixed.

At the time of all this happening, I had an Orchard install version 1.3.10 and I had the following modules installed:

Code Generation
Designer Tools

Jan 25, 2012 at 10:49 PM
Edited Jan 25, 2012 at 10:49 PM

I'm getting this problem when I try to add a new tenant. it appears the new tenant db is missing this table. I copied a db from another tenant and it started working (for now). Pretty frustrating stuff.

Jan 26, 2012 at 5:24 AM

Please file a bug with a repro.

Mar 28, 2012 at 1:35 AM

I filed a bug here:

The problem occurs on a fresh install of Orchard 1.4 as well.