lost functionality - url alternates and shape tracing

Topics: Customizing Orchard, General, Troubleshooting
Jun 2, 2011 at 8:47 PM

not sure what happened, but i lost the url alternates and shape tracing. they are installed, i've uninstalled and reinstalled, but no avail.

i do see the bar at the bottom of the screen, but it doesn't come up with url alternates when i click on an item, nor does it navigate to the proper shape when i click on it.

any ideas?

Coordinator
Jun 2, 2011 at 8:50 PM

Refresh the browser cache. CTRL + F5

Jun 2, 2011 at 8:53 PM
sebastienros wrote:

Refresh the browser cache. CTRL + F5

no avail. tried that. also tried various browsers.

Coordinator
Jun 2, 2011 at 8:54 PM

Check the logs in app_data

Jun 3, 2011 at 2:11 PM
Edited Jun 3, 2011 at 2:12 PM

aha! i didn't know about the log files. here's what i'm getting in error over and over...

 

2011-06-02 16:26:21,119 [16] Orchard.ContentManagement.DefaultContentManager - NullReferenceException thrown from IContentHandler by Orchard.Blogs.Handlers.BlogPostPartHandler

System.NullReferenceException: Object reference not set to an instance of an object.   at Orchard.Blogs.Handlers.BlogPostPartHandler.GetItemMetadata(GetContentItemMetadataContext context)   at Orchard.ContentManagement.Handlers.ContentHandler.Orchard.ContentManagement.Handlers.IContentHandler.GetContentItemMetadata(GetContentItemMetadataContext context) in d:\TeamCity\Projects\Orchard-Default\src\Orchard\ContentManagement\Handlers\ContentHandler.cs:line 305   at Orchard.ContentManagement.DefaultContentManager.<>c__DisplayClass40.<GetItemMetadata>b__3f(IContentHandler handler) in d:\TeamCity\Projects\Orchard-Default\src\Orchard\ContentManagement\DefaultContentManager.cs:line 362   at Orchard.InvokeExtensions.Invoke[TEvents](IEnumerable`1 events, Action`1 dispatch, ILogger logger) in d:\TeamCity\Projects\Orchard-Default\src\Orchard\InvokeExtensions.cs:line 19

Jun 3, 2011 at 3:31 PM
Edited Jun 3, 2011 at 3:31 PM

i do see this in firebug in firefox which may be blocking.

/Modules/Orchard.DesignerTools/scripts/orchard-designertools-shapetracing.js

 

// render the template
340 if (currentShape && shapeTracingMetadataHost[currentShape]) {
341 $("#shape-tracing-tabs-shape-template").tmpl(shapeTracingMetadataHost[currentShape]).appendTo(shapeTracingMetaContent);
342 }

error it shows is ... $("#shape-tracing-tabs-shape-template").tmpl is not a function
Jun 3, 2011 at 3:57 PM

Are you sure you haven't just got a corrupted file somewhere?

Jun 3, 2011 at 5:56 PM
randompete wrote:

Are you sure you haven't just got a corrupted file somewhere?

good suggestion. i replaced the entire folder Orchard.DesignerTools. but still didn't work. i had 4 custom theme files and i renamed them to .old - still didn't work. i'll keep looking.

Jun 3, 2011 at 7:05 PM

FIGURED IT OUT!!!

there was another script that was bringing in jquery 1.4.2 which was apparently conflicting with 1.5.3 that orchard brings in. and also didn't like the jquery.tmpl plugin due to the conflicting jquerys.

hopefully this helps someone else.

Jul 9, 2011 at 5:00 PM

Tradeburglar,

Thanks, you saved me.  I had bought a theme from Bind which brought in an older copy of jquery to drive a slider.  I was getting the same errors.  Once I removed the older jquery, everything worked.  Thanks Again!

Jul 9, 2011 at 5:03 PM

glad to hear it helped!