Anyone else with hg pull problems?

Topics: Troubleshooting
May 27, 2011 at 1:14 PM

Today I always receive:

pulling from https://hg01.codeplex.com/orchard
searching for changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: stream ended unexpectedly (got 2668 bytes, expected 1886152975)
[command returned code 255 Fri May 27 15:08:12 2011]

 

Expected 1,8GB?

May 27, 2011 at 2:08 PM

I get the error "patch cannot be decoded" ... definitely something wrong!

Coordinator
May 27, 2011 at 5:29 PM

We are aware of the problem, which is also affecting us. CodePlex has been notified and the issue is being looked at. Thanks for your patience.

Developer
May 29, 2011 at 2:11 AM

Good not to be alone with the problem:) Have the same and hope it's nothing serious.

May 29, 2011 at 3:24 PM

I can confirm that I am having the problem today as well.

Developer
May 29, 2011 at 5:23 PM

Any news on the topic?

Coordinator
May 30, 2011 at 3:32 AM

The repository is corrupted, the codeplex team should restore it tonight based on another one we were using in the meantime.

Coordinator
May 30, 2011 at 6:02 AM

The repository should be back online now. Please let us know if you notice any problem.

Aug 30, 2012 at 8:30 PM

not sure whether it's back again - but am having it trying to get a rev

 

% hg clone --noupdate --rev e0b6538b8b4d --verbose -- https://hg01.codeplex.com/orchard .
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abortar: stream ended unexpectedly (got 729009 bytes, expected 2117644)
[o comando retornou o c�digo 255 Thu Aug 30 20:53:15 2012]

 

and the default!

% hg clone --verbose -- https://hg01.codeplex.com/orchard .
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abortar: stream ended unexpectedly (got 6 bytes, expected 80)
[o comando retornou o c�digo 255 Thu Aug 30 21:20:00 2012]

anyone else having issues?

don't notice problems this end, I did a stream test (youtube) and there's no connection breaks.

Aug 30, 2012 at 9:18 PM

Happened to me as well. Changed the url to https://hg.codeplex.com/orchard and it seems to work now.