Publish & Deploy Orchard to Shared Hosting

Topics: General, Installing Orchard, Troubleshooting
May 23, 2011 at 5:36 PM

On previous versions (1.1, 1.0), I could right-click publish the Orchard.Web project in Visual Studio to a local directory and then ftp all the files up (using filezilla for speed) to my shared host discount asp .net and get things running without any problems.

After some custom development against 1.x, and confirming my published files work locally by creating an IIS web application on the local directory, I tried about 8 times this weekend to ftp both debug builds (about 550mb) and release builds (about 50mb). Unfortunately, I could not get my application to run at the address:

 http://blogs.climbfind.com/

This morning I cloned a clean grab of the latest integration build just to make sure I didn't screw something up in my custom build. The only thing I did was cook a default recipe. I tried both a release publish build & a debug build. I still could not get even these to run.

Any ideas?

May 23, 2011 at 5:41 PM

I also uploaded the following DDLs to the bin folder just to make sure I wasn't missing any dependencies on MVC3 stuff

Microsoft.Web.Infrastructure.dll

NuGet.Core.dll

System.Web.ApplicationServices.dll

System.Web.Helpers.dll

System.Web.Razor.dll

System.Web.WebPages.Administration.dll

System.Web.WebPages.Deployment.dll

System.Web.WebPages.dll

System.Web.WebPages.Razor.dll

No difference.

Coordinator
May 23, 2011 at 10:23 PM

This most definitely works. What is the exact error?

May 24, 2011 at 12:04 AM

I get a different error each time I do it... Most recent:

Data at the root level is invalid. Line 1, position 1.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Xml.XmlException: Data at the root level is invalid. Line 1, position 1.

I've not been on the best connection in Colorado. Try again from New York tomorrow.

Coordinator
May 24, 2011 at 12:07 AM

You probably missed something when deploying but it's pretty much impossible to tell what from just this. You would need at least to see what that XML document is. If you could debug into it, or give the full stack trace, that would help.

May 24, 2011 at 7:12 AM
Edited May 24, 2011 at 7:18 AM

I literally tried to deploy orchard about 10 times over the last 3 days. But the connections was not super stable and filezilla was reporting failed uploads which I re-queued and reprocessed.

I've been in the airport for about 20 minutes and thought I'd give it another shot. Turned out to be the network I was on. Must have been corrupting files on the way up.

I might write a post about how we customized it to be flexible with what my writers wanted, later this week.

Coordinator
May 24, 2011 at 7:14 AM

Looks super fast too.